Postgres Introspection doesn't work in new version

I use DataGrip to manage multiple Postgres production databases.  I can hardly believe this hasn't been addressed but since upgrading to the newest 2016.2 version, but the introspection seems completely broken.  When I go to the configuration and add a new schema for example, and ask it to synchronize, it just ignores everything new.  It doesn't seem to do anything.  In fact, since the upgrade, I haven't seen anything synchronize successfully.

I did notice that now I have to click on "more schemas" and individually select schemas.  Why?  And this list is not alphabetical.  Even when I choose a schema from this list it does not synchronize.

Please help me understand this.

18 comments
Comment actions Permalink
Official comment

It's fixed, expect it in 2016.2.2, please.

Comment actions Permalink

How long until the patch will be released? Or are there any workarounds before then? This is a frustrating issue.

Edit: Seems restarting the app gets it into the right state at least.

0
Comment actions Permalink

It does not appear to be fixed in 2016.2.3.  Can you please let us know whether there is a new target version for the fix?

0
Comment actions Permalink

Sorry, to be clear, that is the 2016.2.3 version of IntelliJ IDEA in which it does not appear to be fixed.

0
Comment actions Permalink

Just downloaded 2016.2.2.  While introspection is working, nothing has changed about being able to select more than one schema at once.  I don't understand why this was changed - why do I pick my schemas from config and then I have to pick them again from the database window?  It should show me all the ones I chose.

0
Comment actions Permalink

From the config — you mean datasource properties? There are options about resolving (understanding inside the script), not showing.

To choose several schemas in More Schemas... choose them with Ctrl pressed. Is it what you'd like to have?

0
Comment actions Permalink

Yes, here's what I mean:

Previously, in Data Sources and Drivers, for a given DB, I would go to Options, and choose all of the schemas I want to introspect.  When I applied changes, all those schemas would show up in the database view, which makes sense.

But now, in the database view, none of those schemas show up.  I have to do what I did above over again by clicking "More Schemas", and individually click each schemas that I *already* picked in the Data Sources and Drivers/Options.

To answer your question, no, I don't want to have to Ctrl click, because some databases have 100s of schemas, and I already picked all of them in the Options.  Ctrl clicking them would be tedious.  I'm just not sure why y'all decided to have an extra step "Add to View".  I thought that was implied by choosing the schemas I want to introspect in Data Sources and Drivers/Options.

In most other editors I've used, it's the *default* behavior to show ALL schemas in the database view.  But it's really not straightforward to even achieve this currently in DataGrip.

Does that make sense?

0
Comment actions Permalink

Jeremy, it does. We will improve this interface and we understand that now it is a little bit not obvious.

We will improve this interface and we understand that now it is a little bit not obvious.

Now, to choose ALL schemas, please click Ctr+A → Enter on schemas dropdown. For now, there is no way to connect your choice from Drivers/Options to More Schemas...

 

0
Comment actions Permalink

I'm not sure what was recognized to be broken or fixed, but in the current version of PyCharm (2016.2.2) the support for Redshift database is simply broke, which has been working fine for last 1.5 years at least.

I can connect to the database using Amazon drivers, but I can't simply get the database view to show the schemas. On options Resolve Unqualified references I see all my tables, but when I select them, nothing happens. When I "Synchronize DB" nothing happens. What is wrong ?

 

-1
Comment actions Permalink

Can't delete my earlier post, but starting a new project from scratch seems to have solved the problem for now.

Sorry for the confusion.

0
Comment actions Permalink

It is fixed in DataGrip 2016.2.3, what is your version of PyCharm? Is it the latest?

0
Comment actions Permalink

Maxim, I'm not sure what the exact changes were, but now introspection is broken in another way.  Now when I choose schemas in the Data Sources and Drivers/Options, they don't appear under by DB connections, and there is no option anywhere to add them.  It appears to be impossible to add any schemas now!  Help please!

0
Comment actions Permalink

You need to choose schemas from More Schemas... here 

0
Comment actions Permalink

What I mean is that I do not see any "More Schemas" button at all... I have version 2016.2.4.

0
Comment actions Permalink

I need to see your screenshot, Jeremy =)

 

0
Comment actions Permalink

I'm sorry but I can't share that publicly, and it would not tell you much anyway.  It is easy to explain.

For SOME of my connections, I see exactly what you picture 3 posts up.  However, for some of my other connections, I do not see that at all.  For example, one of our dbs has dozens of schemas.  I can see 3 of them, and there is no "More Schemas" option showing for some reason here.  When I go to Drivers/Options and choose a 4th schema, save it, and hit synchronize, it just does not show my 4th schema, and it also does not show the "More Schemas" option.  There is no way for me apparently to see it.

Perhaps I just need to try recreating the connection.

0
Comment actions Permalink

In Options tab you choose only schemas for resolving (they can be understood from the script), not showing them in DB view.

Try to press Synchronize button on your data source.

0
Comment actions Permalink

There's another problem here: it is resolving all schemas, even ones that I have not chosen, which includes pg_temp% and pg_toast%, and this is taking very long.

I have pushed the synchronize button - it is still never showing "More Schemas".

0

Please sign in to leave a comment.