Can't use PSI in Phpstorm plugin

Answered

Hello,
I'm trying to build my own plugin for Phpstorm. I'm currently trying to add a custom line marker using the PsiLiteralExpression class to check the type of the element. It works perfectly when testing the plugin with IntellijIdea, but when I test it with Phpstorm 2016.2 it throws an exception : java.lang.NoClassDefFoundError: com/intellij/psi/PsiLiteralExpression

Any idea on how to fix that ?

0
1 comment
Official comment

PsiLiteralExpression is part of Java PSI and thus not available in PhpStorm.

Please sign in to leave a comment.