Simple Startup Problem

Answered

I have PyCharm CE,  Phthon 3.5 running on iOS 10.11.5. I create the file, etc., and something runs, but nothing appears. If I cut and paste the file (simply: print("Hello, World") into the Python Consol it works. So does 2+2. But if I click Run (any of four places, green arrow upper right corner, lower left Run window, or the two Run options under the Run menu, I don't see any results. After a flash it says: Process finished with exit code 0. Empty test suite. and No tests were found. The same things happens whether I choose Python Consol or Terminal in the Run/ lower left window.

I don't know where I've set something about tests up, but more importantly I don't get any output. I'm probably missing something obvious but I'm stuck.

4 comments
Comment actions Permalink

Please remove the existing Run configuration for your file in Run| Edit Configurations and run your file using right-click context menu again. Does it help?

0
Comment actions Permalink

Yes, using right-click on the .py file, and then Run worked and the output appears. Thanks very much. Since I have a Macintosh, the right click is apparently the only way for the Run to work - the menu items don't work. I appreciate your suggestion.

0
Comment actions Permalink

I have the same issue. Can't believe the lack of support on this seemingly simple issue.

0
Comment actions Permalink

Does it work if you right-click on your file and select "Run <file_name>"? Please provide screenshot of the issue.

P.S. Most likely something is wrong with your run/debug configurations so make sure you're familiar with how they work: https://www.jetbrains.com/help/pycharm/creating-and-editing-run-debug-configurations.html

0

Please sign in to leave a comment.