PyCharm not opening on Windows 10

Answered

This has been happening on and off for me for a couple of weeks now. Whenever I try to launch PyCharm from the stat menu, it almost feels like there's a 50/50 chance of the window actually popping up. Can't put my finger on it as to why it happens. I also don't necessarily see a new process show up in my Task Manager. Trying the .exe's in the bin folder has the same behavior. 

Using Windows 10, Java is up to date

Has anyone encountered something similar? 

27 comments
Comment actions Permalink

This happens to me occasionally as well since updating to 2016.2 (from 2016.1) on two separate Windows 10 machines.

Occasionally the splash screen doesn't appear. Other times, the progress bar on the splash screen updates for a few seconds then just hangs. Eventually I just kill the pycharm.exe process and try it again and it loads ok.

0
Comment actions Permalink

The problem that I have is that I don't even see the pycharm.exe process pop up in my Task Manager. 

0
Comment actions Permalink

We need your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files) for investigation. You can also upload a file via https://uploads.jetbrains.com form and let us know the exact file name.

0
Comment actions Permalink

I have the same issue: Try to start Pycharm 5.0.3 on Windows 7 and the window is popping up for one second and disappears. I can't use PyCharm any more. Are there any solutions?

0
Comment actions Permalink

This worked for me:


1. Reboot your machine


2. Go into C:\Users\mschmitt\<Pycharm folder>\system\tmp


3. Delete everything in there


4. Start PyCharm

4
Comment actions Permalink

No need to reboot! (at least, not for me, so try first by just removing the tmp folder, then if it doesn't work, reboot)

Thanks a lot Mschmitt!

1
Comment actions Permalink

@Anna Morozova: I checked, and the idea.log didn't contain any new lines since it stopped working. Apparently it didn't even get to that point (and I'm in the right log because it contains the shutdown info of yesterdays' run)

0
Comment actions Permalink

This happens to me all the time. @Mschmitt's workaround has always worked for me in the past, but today, for whatever reason, I am completely locked out of PyCharm. Always happens right after an update. Is this on the radar to get fixed?

Switching to VS Code for now :/

0
Comment actions Permalink

This happened to me today out of the blue.

Deleting the tmp directory did not help.

I downloaded the latest pycharm from jetbrains.com and re-installed it.

I had the latest version already but it was the result of multiple upgrades.

Re-installing (but keeping my settings and projects) fixed the problem.

0
Comment actions Permalink

Neither of the above tricks worked for me:

1) deleting tmp then launch or
2) uninstall then reinstall then launch with no settings imported and into a new project.

Being stuck with unresponsive PyCharm for the last 2 days.
Is it solely the Community version or the paid one too has same problems?
 

0
Comment actions Permalink

Hi Frederic! So you are able to start PyCharm but can't open any project right?

0
Comment actions Permalink

hello,

I have managed to pass through my hurdles by running PyCharm the first time after install as an admin.
Then everything got indexed/updated. I am now able to open my projects, load some python files and execute them.

After some further testing, I found that the old workspace.xml is making my new install become unresponsive upon opening
(pycharm windows doesn't fully redraw as it manages to only display the border then hang there).

All in all, I am back at work after a good scare.  

 


 

0
Comment actions Permalink

Deleting everything from .PyCharm*\system\tmp solved the problem. However, I have few folders (.PyCharmCE2016.3, .PyCharmCE2017.1 and .PyCharmCE2017.2) and  I'm starting PyCharm Community Edition 2017.2.2 so I had to clean up temp folder from all that PyCharm folders. If I've cleaned only the latest version it didn't work.

 

This problem emerges when I start PyCharm but click on Exit while it is still starting up.

0
Comment actions Permalink

I just downloaded pycharm onto my windows 10 laptop and it just will not open i gave tried uninstalling and reinstalling but it still will not work. 

0
Comment actions Permalink

Hi, same problem here. I tried deleting tmp folder and pycharm isn't running in task manager as far as I can tell. The only logs contained within the logs folder are the ones from my startup the night before.

Running Win 10, and latest version of pycharm. Any fixes for this?

1
Comment actions Permalink

I had exact the same problem with PyCharm on my Windows 10 ver 1511 (50/50 chance to start PyCharm), but after upgrading Windows 10 to ver 1607, can't run PyCharm at all.

1
Comment actions Permalink

Just an update for anybody else with the same problem, I had to do a clean uninstall/reinstall and now it's starting up without issue. Not exactly a fix for whatever caused this issue in the first place, but at least it's working.

0
Comment actions Permalink

Anytime I open my PyCharm community version, it shows me this error:
(If you already have a 64-bit JDK installed, define a JAVA_HOME variable in Computer > Systems Settings > Environment Variables.

Failed to create JVM.JVM Path: C:\Program Files\JetBrains\PyCharm Community Edition 2019.2\jbr\ )
And I have the latest java but everything is in it's path but it still doesn't want to work.

0
Comment actions Permalink

This happened when I upgraded from PyCharm Professional 2019.1.2 to PyCharm Professional 2019.2.

- Reinstalling is useless.

- Removing files from tmp folders is useless.

- Removing the .vmoptions is useless.

OS: Windows 10 Professional

Everything is officially authenticated, not a cracked version.

0
Comment actions Permalink

>Removing files from tmp folders is useless.

Did you try to remove .PyCharm2019.2 from the user home folder? Could you please take a screenshot of the error?

0
Comment actions Permalink

run pycharm by pycharm.bat file solved for me

0
Comment actions Permalink

Nothing was showing, I removed .PyCharm2018.1.3 .PyCharm2019.1.2 .PyCharm2019.2, uninstalled the PyCharm and reinstalled it, and it worked.

0
Comment actions Permalink

Just today I had this problem with IntelliJ IDEA. My custom vmoptions file in %userprofile%\.IntelliJIdea2019.2\config was corrupt. After deleting it (idea64.exe.vmoptions for IntelliJ), I could start again.

0
Comment actions Permalink

This may be relevant if you use multiple monitors (or not).

In my case, it was "opening" the PyCharm windows at ridiculous screen co-ordinates (e.g. -32767, 11000) and dimensions, which meant I could never see the windows when they were open. Perhaps this happened when it tried to adjust for (un)plugging my monitors.

You could check the settings are sensible for your project -- for me, they were here:

C:\Users\<your username>\PycharmProjects\<your project>\.idea\workspace.xml

see what the values of x, y, width, height are for various components, make sure they are >= 0 and less than your screen width/height, e.g.:

<component name="ProjectFrameBounds">
<option name="x" value="0" />
<option name="y" value="0" />
<option name="width" value="600" />
<option name="height" value="600" />

... and perhaps other dimensions appearing in the same file, such as (for me):

<component name="ToolWindowManager">
<frame x="0" y="0" width="100" height="600" extended-state="0" />

or otherwise snoop around the PyCharm folders, e.g. I also had a folder C:\Users\<username>\.PyCharmCE2018.2

0
Comment actions Permalink

I use PyCharm2019.2 version,

1.delete /tmp is useless.

2.uninstall and reinstall is useless.

3.delete C:\Users\{USER}\.PyCharm2019.2 works for me.

0
Comment actions Permalink

Experienced this problem upgrading from PyCharm2018.3 to .PyCharm2019.2

Tried all of the above; nothing fixed it

Narrowed problem down to importing settings from 2018.3 to 2019.2

Fixed it with:

 - remove 2018.3 as best I could (wasn't finding uninstall exe)

 - ran ccleaner several times to clean registry

 - removed existing path to PyCharm in Environment Variables (start menu > type Environment Variable)

 - fresh install of 2019.2

 - not importing settings from old PyCharm2018.3 folder (which, also, I had renamed for certainty "_PyCharm2018.3")

 - not pointing to existing projects in PyCharm Projects folder; instead recloned projects from GitHub

Working on Win 10 on PC

0

Please sign in to leave a comment.