[SOLVED] Tab switch lagging after 2016.2 update

UPDATE: Found that CodeGlance plugin (http://plugins.jetbrains.com/plugin/7275 ) is causing the issue.

After updating to 2016.2, whenever I try to switch between open tabs/files (by default Ctrl + Tab shortcut) there's a huge lag, around 4-5s - and sometimes it even hanged the java process, forcing me to kill it.

This seems to happen only on large projects. 

I've experienced it first right after updating 2016.1 > 2016.2, then on this first "lagged session" - which lasted for almost a minute - WebStorm itself informed me that vmoptions (from ~/.WebStorm2016.2/webstorm64.vmoptions) needed tweaking. I had that done for 2016.1 but it seems something changed/reset for 2016.2. I changed it again, with -Xmx2048m but only that. It seems to be better, but it still lags and it's really becoming an annoyance.

Anyone with something similar? Any tips on what I should try or how I could debug this? Thanks.

Note, system specs:

  • updated Linux Lubuntu 16.04
  • WebStorm using built-in openjsdk (1.8.0_76-release)
  • 12GB RAM (usually 50%+ free)
6 comments
Comment actions Permalink

Thank you Elena, I'll do it.

0
Comment actions Permalink

Elena, I did the CPU snapshots, the memory ones are 'a bit huge', I wonder if we can have any clue only with the CPU for now? (if not, and I think we can't, I'll upload them).

If yes, please take a look of the scenery:

- It's a server project, written mostly in Node. Has around 130k files (including libraries files).

- In the snapshots situation, the project is open with 10 tabs open. When open, the project stays around 20-30s indexing, plus around another 20s "syncing" (the bottom-left circular icon).

While creating the snapshots, I found something that can be useful: after the .vmoptions tweaks it got "less worse", yet the initial Ctrl+Tab (as soon as indexing and syncing are over post-opening the project) takes about 4-5s - but then after this initial one every other Ctrl+Tab works without any major delay, as used to be. But then, if I Alt+Tab out from WebStorm to any other application and get back (i.e. just alt+tabbing to File Manager then going back to WS right after it) the delay happens exactly the same way again, around 4-5s.

So I did 2 CPU snapshots:

#1. Restarted WS. Waited for the project to end opening, indexing and syncing. Started CPU profiling. Did Ctrl+Tab (3-5s delay here) and held the keys until Switch Tab dialog appears and selected the next tab. Did Ctrl+Tab again, no delay. Stopped CPU profiling. https://drive.google.com/open?id=0B-yhgiBz9FcKend0MUxmYzFEYTQ 

#2. From the exact point from #1's end. Alt+Tabbed to another application and Alt+Tabbed back to WS. Started CPU profiling. Did Ctrl+Tab (3-5s delay here) and held the keys until Switch Tab dialog appears and selected the next tab. Did Ctrl+Tab again, no delay. Stopped CPU profiling. https://drive.google.com/open?id=0B-yhgiBz9FcKVTU5YWxzWVdzR3c 

 

Can you analyse anything with this info? Thank you.

 

 

0
Comment actions Permalink

Unfortunately snapshots didn't give us any clue:( Try turning editor tabs off (Settings|Editor|General|Editor Tabs|Placement -> None) - does it make the performance better? please try disabling 'Synchronize files on frame activation' (Settings | Appearance & Behavior| System settings) - does it help? Also, can you attach your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)?

1
Comment actions Permalink

Elena, first of all thank you and WS team for your help.

While trying your suggestions I found the culprit: CodeGlance plugin http://plugins.jetbrains.com/plugin/7275 . My guess is that it's slowing down everything on tab refresh/etc wnem not from cache. After deactivating it no delays anymore.

Sorry, I should have tried to disable all plugins before everything, I got distracted by the vmoptions hints at it. Thank you again for your support.

0
Comment actions Permalink

Hiding the tabs did improve the tab switching speed for me

0

Please sign in to leave a comment.