How to get HTML tags to auto-close?

In other editors if I type tag <table> then when I type </ it will put </table> for me but it isn't working in PHPStorm and I'm unable to find a solution online or in Settings.

If you have the solution please check that it works first. PHPStorm 10+

3 comments
Comment actions Permalink

The only option that's available:

Settings/Preferences | Editor | General | Smart Keys --> Auto-close tag on typing '</'

1
Comment actions Permalink

Yes I found that but it isn't working.

0
Comment actions Permalink

What exact file type are you editing? Simple HTML, or something else?
I've just checked, it works for a simple HTML file, but does not for any template language, here's the issue:
https://youtrack.jetbrains.com/issue/WEB-14119

0

Please sign in to leave a comment.