Sudden "Unable to display frame variables"-error...

Answered

After I updated PyCharm recently, my debugger has stopped functioning and I have no clue what to do to fix this... The debugger connects fine and exits on set breakpoints but inspecting frames is not an option anymore.

I tried quite a lot to fix this but nothing seems to work, which is sort of depressing given the fact that my work just got way harder...

If anyone has experienced these problems and has found a solution, I would definitely love to hear about it.

Thanks in advance!
Michiel.

6 comments
Comment actions Permalink

I also enabled Gevent-support in the debugger-options as was suggested in another online topic concerning this problem. Did not work for me either.

0
Comment actions Permalink

Hi! Do you debug your program locally or remotely? If remotely, there is know bug in our tracker https://youtrack.jetbrains.com/issue/PY-20198, you can find a workaround until the bug fix update isn't available.

If it doesn't help, it also might be related to breakpoint's thread suspend policy. It has appeared in PyCharm 2016.2. You should go Run | View breakpoints, select the breakpoint and select its threads suspend policy "All" or "Thread".
"Thread": when the breakpoint is hit, the thread where the breakpoint is hit is suspended.
"All": when a breakpoint is hit, all threads are suspended.

In the previous versions of PyCharm the default policy used to be "Thread", but it's become "All" since PyCharm 2016.2. When you change breakpoint's policy, the button "Make default" appears and you can save new default policy for all your breakpoints.

0
Comment actions Permalink

Thanks! This seems to be exactly my problem. I'll have a try with your suggestions and will report back ASAP.

0
Comment actions Permalink

Hello, For me it was caused by memory. If I reduced the size of my Pandas frames, the error went away.

0
Comment actions Permalink

Hi, what about idea 2016.2.4 ultimate? Has same problem.

0
Comment actions Permalink

I also use remote debug using Pycharm2019.3. You should try to put the Pycharm Debugger in gevent compatible mode.

File > Settings > Build, Execution, Deployment > Python Debugger > Gevent compatible

The lines you removed probably had a purpose and you shouldn't delete them without knowing the consequences.

 

Ref. https://stackoverflow.com/questions/40865488/why-does-pycharm-say-unable-to-display-frame-variables-in-debug-mode 

0

Please sign in to leave a comment.