messed up support of high-DPI screens

It seems that some apps totally don't get it how to behave with high-dpi screens. In my case webstorm is one of the worst offenders (and I expect all others from storm family to have that issue); perhaps that's java's "inherited" problem or even Win10's failed handling on high DPI displays. So, here's a few things that I noticed that doesn't work properly with webstorm. In my setup I have a remote desktop pc that's physically attached to a 4K high DPI screen. I connect remotely using mstsc to that pc, and computer that I'm using to connect from has a regular screen.

In this setup there are two possible combination when I login: (1) if I was already logged in on that remote pc and effectively RDP attaches me to existing login session, or, (2) if I wasn't logged in remotely and new session is created when I log in using RDP. Behavior that I get is quite different with WebStorm in these two scenarios. First or all, I expect identical outcome in (1) and (2), but perhaps it's Win10's issue that result isn't the same. Since I'm connecting from regular display I also expect the same behavior as if I was physically attached with that non-high DPI screen.


I'll attach here's screenshot for (2), in (1) it's not as bad.


PS. I also added relevant post on MS forums: Fail: handling of high-DPI/4K monitors in Win 10



looks similar to Please try switching UI theme to 'IntelliJ' in Settings/Appearance & Behavior/Appearance - does it look any better?


Screenshot provided in  is exactly what I had in (1). With IntelliJ UI theme I don't see size issues, however, the theme itself is the issue: IMO dev tools should use native controls, otherwise it feels like some kind of toy.


By the way, when I go to settings dialog, it's completely messed up also, it uses GIANT font, each letter is bigger than a title bar of a regular window (IntelliJ theme also fixes size in this dialog):


It looks also similar to this:

In my case I shut down remote PC, unplugged the screen, then restarted it and logged into it remotely while 4K screen isn't attached and not problem is gone. The only minor issues that I see is the vertical text on the tabs on the left of the window:


Just wanted to follow up. I'm pretty sure it's a windows 10 bug. However, for some reason only some apps are affected, and others aren't.


Is there a real fix for this issue yet?  I don't want the Intellij theme as I prefer the darker IDE.  I also don't want to go blind squinting to see items in the project explorer on my UHD monitor or have fonts so big I have to spend several minutes resetting things just to use the laptop screen.  I know this is a lower priority issue, but it is the singe issue that stands between me and money for JetBrains come renewal time in a month or so.



I'm having serious issues now that I have a super cool alienware 13 r2 laptop.  I mean, it's cool except for the many issues with the high resolution affecting some programs etc.

I am using the IntelliJ theme and everything is tiny.  I can update the setting so mouse zooms font and that's great, but my outstanding issue is that the project tree is tiny and I need that to pick up the default 250% Windows 10 scale factor as well or I can't see the tree.  

Anyone with updates or other approaches?


@Willthompson2012 The problem is that the IDE UI is currently limited to 2x scale... Please follow for updates


Could it be related to this, fixed in Windows 10 Creators Update?

I am having fuzzy, hard to read fonts on Dracula theme on my secondary screen (Full HD), using my Surface Pro 4 (main screen has very high resolution, beyond HD)


This problem occurs for me every time I unplug my laptop from my hi-DPI screen (using the second screen only when plugged in).  Closing and opening Intellij resolves the issue, but takes a long time.  No other applications suffer from this - Slack, Chrome, Sublime, even Conemu running my terminals manages to correctly scale (each monitor has different scaling settings in Settings > Display > Scale and Layout).  I believe it's this scaling that causes the problem; if I change it, Windows even gives me a message that says "Some apps won't respond to scaling changes until you log out", however Intellij is the only application that doesn't respond correctly.

Intellij should be able to cope with being plugged into a hi-DPI monitor.  Even an option to reload the interface would be useful, as having to shut down all the processes that I run in Intellij is extremely painful and costs a lot of time. If I do this twice a day, in real terms I'm often losing 30-45 minutes getting my REPL and db results up and running again.


I experience a similar problem. I'm using Intellij Ultimate 2017.2.2 (Windows). After detaching/attaching my monitor the layout is rescaled (it becomes huge comparing to the resolution). I have to restart IDEA as a workaround which really impacts my work.


This problem made my work-day quite miserable. The problems seems to be in the Swing technology all JetBrains IDEs are based on. High DPI support seems to be a limitation of the Swing technology [1], [2], [3]. Unfortunately, Swing seems to be totally dead since 2006 - when it got minor updates on its JSR [4].

But now my problems are solved. Moving to Atom or VS Code solves these problems with a simple Ctrl +/- because it is based on web technology that is made to fit on any device with any screen at any screen resolution. It took me a while to get used to such switch but once you master the 'code editor' it it seems to be quite powerful although it is not full fletched IDE. As a side effect this switch made me to work more with the terminal. 

Too pity, I was big fan of JetBrains (and I am still) but it is bad for your eyes to work with their IDEs on high DPI screen.







Please sign in to leave a comment.