Annoying behaviour with quotes in Angular2HTML Fragment editor.

When I go to edit HTML in my TypeScript (Angular 2 app) I usually bring up the intentions menu to put the HTML in its own editor and I'm experiencing some behaviour that only happens in this editor window, but not when I edit the template string directly..

If I type: <button class="

the editor inserts the second " as I expect.  I fill in my classes and then type a ".  If in the intentions editor I now have 2 closing quotes.  If I edit the html in the template string directly, it does not add a second quote as expected.  

I have the same issue in Intellij.  And it used to work properly.  Broke in the last few months I think.

Is this just a change to a configuration setting?

 

Thanks.

0
1 comment

please vote for https://youtrack.jetbrains.com/issue/WEB-23104; there are no settings that control this (but you can turn quotes completion off in Settings/Editor/General/Smart Keys, 'Add quotes for attribute value on typing '=' and attribute completion' to avoid adding closing quote)

0

Please sign in to leave a comment.