Forwarding of port 9000 not working with PHPStorm (Xdebug)

It's a Linux server running in Vmware which should be accessed from the host (Windows)...

NAT is working but XDebug cannot connect back to the client.

Bridged network is working without any problems.

 

Forwarding of port 9000 is not working.. PhpStorm says the port is in use and cannot be used. No idea why?
Is SSL tunneling of port 9000 the only solution if NAT should be used?

3 comments
Comment actions Permalink

Hello,

Did you check what is using that port with `netstat` or any similar tool?

0
Comment actions Permalink

Yes, it shows that PHPStorm is using this port. The preferred way seems to be to use SSH tunneling so my question why NAT port forwarding in VMware is not working

0
Comment actions Permalink

In this case, no additional configuration is needed, I believe.

> It's a Linux server running in Vmware which should be accessed from the host (Windows)...

So, PhpStorm runs on the Windows machine (let's say 192.168.0.1), and the web server is a Linux (let's say 10.10.0.1) behind a NAT, right?
Which means that the Linux machine should be able to connect to Windows, if you haven't done anything tricky with the NAT.

What if you enable Listening for incoming connections and then try telnetting to 192.168.0.1:9000 from the Linux machine?

0

Please sign in to leave a comment.