DataGrip does not show tables under schema


I have configured my database in DataGrip and everything works fine except that I cannot see the tables under schema. I have similar configuration for other database, which has no problem at all. Is there any setting I missed?

As you can see in the screenshot, tables show up in the database "Snapmobile". However, nothing show up in "Pixels Redshift". Both databases are AWS Redshift.




I have the same problem, it will be very helpful to solve it


I have the same problem. Cannot see any tables.


Please, note that for PostgreSQL-based DBs is "one connection — one database", so make just another datasource for Pixels.


Hi Maxim,

Thanks for your reply.

In my case, the Pixels and Snapmobile are two different datasources. However, I still cannot see the content under the public schema. Any idea why?


Yeah I see, thanks!

Can you please tell what version do you use?

And if it works on 2016.1 (You can download it here:



Hi Maxim,

The version I am using now is 2016.2.1 BUILD #DB-162.1628.37, build on August 15, 2016. I haven't got time testing the earlier version yet. I will let you know once I did.




So, the fact is: you have 2 instances and one is introspected, and the other is not. May be you have different type of rights on Pixels?



You are right. I have 2 instances connecting to 2 different Redshift. Both 2 users have the admin permission. Although Pixels is not introspected, I can run this query

select * from pg_catalog.pg_tables where schemaname='public'
order by tablename;

to get all the table information and I can do all the read/write queries on those tables. So I think it is not permission issue.

I just did another test, create a another connection to Snapmobile Redshift, it is not introspected.


I have the same problem.


Hi Maxim,

I have tested a few old version of DataGrip:

DataGrip      1.0.3 Build#DB-143.2263, build on Feb 18, 2016
DataGrip 2016.1.1 Build #DB-145.863, build on May 6, 2016
DataGrip 2016.1.2 Build #DB-145.864, build on July 4, 2016

Surprisingly they all work!

I found that since version 2016.2 there is a UI/UX change, you have to manually add those schemas to view.

In previous version, by default, those schemas are all visible, and information downloading starts automatically once the data source is set.

I can see the downloading progress bar in the older versions and once everything is downloaded I can see all the tables under the public schema. I have a feeling that it could be this change caused the table information not downloaded.

I hope this can help you resolve the issue.




Thanks! So, first you needed to press SYNC button, and then More Schemas... appeared, right?

Am I getting it right, that now Pixels is introspected, after you used More Schemas...?


Hi Maxim,

I need to follow a strict configuration order to make the tables appear:

1. Enter credentials and click "Test Connection" button (this is a must). And DO NOT click the "OK" button to exit the config window.

2. Click the options tab, click all the check boxes of the schemas under "Resolve unqualified references". At this moment the "introspect metadata using JDBC" option is not there yet. Click "OK" to close the config window.

3. Wait the downloading of the table information. Expand the data source then you can see the tables.

If I do not follow this order I won't get table list.

My issue is solved for now. Thanks!


Hi, guys! Finally, we discovered the reason of this and thank you for your reporting. Lawrence, your workaround is right, and it helped us to explore a cunning thing inside the code-base.

Fix will be in 2016.2.3 which is supposed to be released during these days.

Thanks again!


I'm having the same issue but with SQL server.  I have a database with several schemas, I can query everything (the intellisense aspect works fine), but cannot actually see any tables/views/routines in the database window.  When double clicking on tables in the stock schema I see:

[08004][911] Database 'stock' does not exist. Make sure that the name is entered correctly.

Stock isn't a database it's a schema.

I've got another SQL server that works fine.  Resolve unqualified references has all the schemas ticked.

EDIT: Running latest EAP : 

DataGrip 2016.3 EAP
Build #DB-163.5644.18, built on October 7, 2016
DataGrip EAP User
Expiration date: November 6, 2016
JRE: 1.8.0_112-release-b408 x86
JVM: OpenJDK Server VM by JetBrains s.r.o

EDIT2: Fixed - I removed the connection and re-added and now I can see tables for all the schemas


I am having a similar issue, against a Kerberized Hortonworks Hive.

I was getting "autocommit" errors in 2016.2.6.... I am trying the 3 EAP now....

No more "autocommit" errors, but nothing shows up under my database.

Ive checked all boxes under options/Resolve unqualified references... All tables show up there

Just not in the UI.


Any ideas?



Thanks Max!

A revised jar definitely worked out better.


I seem to be having issues with Netezza. Has this bug been fixed?


We don't directly support Netezza and we didn't know about the bug. What version of DataGrip did you check?


Hi Maxim - I have the latest version. I updated my drivers but this only populates the schema for databases that I have connected to in my URL.


So, do you see schema but not tables?


right click - > Database Tools -> Forget Cached Schema -> Synchorize 

which solved mine with version 2017.01


You guys are going to hate this. I just updated to 2017.1.4 and this problem has cropped up, again. I've attempted the fix suggestions earlier and this do not appear to work.

DataGrip 2017.1.4
Build #DB-171.4694.3, built on May 16, 2017
Licensed to Don Nielsen
Subscription is active until January 13, 2018
JRE: 1.8.0_112-release-736-b21 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 10 10.0

The databases are sql server, and I am using the latest microsoft driver, 4.0.2206.100.

 I have attempted and failed with the following resolution attempts:

  • synchronizing
  • Database Tools / Forget Cached Schemas
  • deleting my project .idea metadata
  • Completely new project
  • I have not attempted re-installation, yet

Master is fine. It shows dbo/tables & views. All other databases do not show anything.Here is what I see...

Any clues? Anyone else encountering this? I believe I had the problem with v2017.1.3, but the Forget Cached Schemas worked for fixing.


"I see said the blind man." When one clicks Schemas to select which databases to display, one needs to click the arrow next to the database name and choose which or all schemas to display for that db. Once chosen, they are displayed in the database window.

That could be a little more intuitive, maybe having "all schemas" be a default?

Consider my particular issues as solved. Unfortunately, I did remove all traces of datagrip and re-installed it to make this little discovery.



>That could be a little more intuitive, maybe having "all schemas" be a default?

It could be a huge problem in cause user has a big amount of schemas. But we need to think about lazy loading of database objects.

Thank you.




I had the same problems but solved this by right-clicking my database > "forget schema". And then push the synchronize button. All the lost tables were shown again! Good luck!




@don nielsen that did the trick! Thanks a lot


I leave a suggestion to the dev team, because the schema has the label informing that is the current schema, but didn't has the tick in the checkbox, after check the checkbox it worked fine. Should be nice:

1 - as don_nielsen said, better UX interface to understand what we need to do

2 - the checkbox be checked so at least we have something and don't have the feeling of a using a buggy version of the app.





I have the same problem and I really tried everything on this thread.

I have Datagrip version 2017.1.5 for Mac.

I also re-installed and deleted everything inside the setting directories


Same attempt I have also done with previous versions.

On a further note, I noticed something different when synchronising and reading the status at the bottom of the window.

I can read briefly a status like "preparing incremental introspection (UNKNOWN)". After that I can read "table list in [db.schema], but nothing happens.

Any idea?



Please sign in to leave a comment.