DataGrip does not show tables under schema


I have configured my database in DataGrip and everything works fine except that I cannot see the tables under schema. I have similar configuration for other database, which has no problem at all. Is there any setting I missed?

As you can see in the screenshot, tables show up in the database "Snapmobile". However, nothing show up in "Pixels Redshift". Both databases are AWS Redshift.




@Brunaodo can you share a screenshot, please? The schema is checked, the table is there, everything is fine on the database side, right?

Anyway, after making a screenshot please try to Forget Cached Schemas and resync.


Hi Maxim, I removed out the connection and reconnected and now it's working fine. I don't think there is a problem with the schema, I can connect to it using PgAdmin just fine, execute queries etc. I will take a screenshot if/when it happens again. Thanks


After upgrading to 2018.3, I experienced the same thing with SqlServer. That was a while ago. It forgot the schemas, noted by the"..." in the attached image.. I refresh them as I need them and all is good with with the world.


DataGrip 2018.3.3
Build #DB-183.5912.12, built on February 19, 2019

JRE: 1.8.0_152-release-1343-b28 x86_64

JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o

macOS 10.14.3

PostgreSQL 9.6


I have a smilar issue.

The tables list is not refreshed when I click on "Synchronize" in DataGrip.

My schema is always changing on my local database due to the fact that I work with different versions of my application and my database migrations are applied on each build according to the version that I am working on.

And yes, I am 100% sure that the tables are actually there because if I select something from the tables that are not displayed in the left panel in DataGrip (under schema/public/tables), the query result is displayed as expected in the console in DataGrip.


Shouldn't' happen!  It only happens with third-party created tables, right?

Please, continue in the issue:



Yes, I meant that, Please write this in the issue. 


post deleted - turns out someone gave me a bad object filter


I have the same problem,I follow the instructions and clean up the cache, but it gets stuck in one place。version 2019.1.1,but I can query with SQL


Hello everybody! This topic seems to be the collection of different problems that look similar. I will kindly ask you to create an issue in the tracker every time you don't see objects in the schema.

This will help us and also you will be able to track the process.



My problem is solved!Method is




Yao Rp, this is not a solution, but a workaround. Please, create a bug in our tracker:
We need to understand what's going on!


I have the same problem in 2019.

Sometimes no tables will be displayed under public on Postgres. If I REMOVE the connection and connect again, it sometimes work.

This problem is making it very complicated to keep using DataGrip =(


@ Andre Pena 
Could you describe your environment and steps to reproduce the issue?


same issue happening with me.


I've two different docker containers both has same database one has a previous version and the 2nd has a new one. On new database I created a couple of new tables now whenever I switch container instead of sync I have to delete the old connection and create a new one.



@Moeen Basra,

>I've two different docker containers both has same database one has a previous version and the 2nd has a new one. On new database I created a couple of new tables now whenever I switch container instead of sync I have to delete the old connection and create a new one.

In your case there is `Forget Cached schemas` or `Force Refresh` actions are suitable.


I had this problem, latest version of DG with a connection to redshift.  The main issue is the introspection fails and the tables are never shown.  I can query them and use them but not see them.  To fix this, go to connection properties -> "Auto Sync All Schemas"  and uncheck "use pre-inspected objects for system catelogs that are not introspected" and check "introspect using jdbc metadata".  Then apply, okay, and refresh the data connection. 


Marc, if that's possible, please send SQL logs to, we will investigate.


Getting the following in DataGrip 2019.3 (Redshift database with driver

Error encountered when performing Introspect database prod schema pg_catalog (details): [Amazon](500310) Invalid operation: syntax error at or near ")"
Position: 584;.
[Amazon](500310) Invalid operation: syntax error at or near ")"
Position: 584;
and 1 duplicate reports (17 s 185 ms)

Consequently, the displayed schema is out of date.


After paying attention ;) the workaround in Marc's comment above seems to have worked for me. 

I'm not sure if or what logs you might want, but happy to send if helpful.


Robert Park,

Regarding your issue follow

At the moment we've got compatibility issues with the latest Redshift JDBC driver.


This issue exists under Pycharm 2020.3.2 where not all tables are visible under schema. I only checked this with Redshift driver JDBC42- with Java SDK


Hi There,

I'm experiencing a similar issue here. Table names are not populating under schema:


Atharva Inamdar

Please, update IDE to the latest version where Redshift JDBC driver v.2 is available.



Are you using Redshift JDBC driver for PostgreSQL engine over localhost? Could you try to user dedicated PostgreSQL JDBC driver for it!


vasily chernov

I upgraded to version 2021, and the problem seems to have been resolved.



Great! Thank you for update!


I'm having this issue after downloading the latest Datagrip onto a new Mac:

DataGrip 2023.1.2
Build #DB-231.9011.35, built on May 16, 2023
Licensed to XXXXX / Brian XXXXX
Subscription is active until July 19, 2023.
Runtime version: 17.0.6+10-b829.9 aarch64
VM: OpenJDK 64-Bit Server VM by JetBrains s.r.o.
macOS 13.4
GC: G1 Young Generation, G1 Old Generation
Memory: 752M
Cores: 12
Metal Rendering is ON


However, in this version of Datagrip I cannot find this checkbox anywhere: "introspect using jdbc metadata".


Hi Brian,

I saw your ticket, where I have already replied with instructions to troubleshoot this behavior. Please check.


I am having this issue as well and this checkbox has been removed in the version I am using:

What am I supposed to do?


Please go through the steps mentioned in this section:

If it doesn't work, please upload the Dump Model (right-click on the data source and Diagnostics from the context menu) and the following logs onto our FTP:

Please sign in to leave a comment.