How to unexclude node_modules in 2016.2.2?

Since upgrading to WebStorm 2016.2.2, it's auto-excluding my node_modules folder. Note that this folder contains my source code, it's not generated by `npm install` or similar. The effect is now I can't find files with shift+shift or cmd-shift-o. If I repeat the shortcut (like cmd-shift-o, cmd-shift-o), that toggles "Include non-project files", and then it can find my files.

It doesn't seem possible to "unexclude" my node_modules under Settings -> Directories, my node_modules folder is red, and has Excluded selected, and it's not possible to unselect.

I can double shortcut for now, but is there a better resolution? Thanks!


So just in case someone else runs into the problem I was having with Sass libraries like Bourbon where you need to add its stylesheets directory as a resource root:

You also need to add the directory as a Library:



@SteveKehlet @SimonPeyou

I had the same problem, but I figured out that the node_modules was ignored in Settings > Editor > File Types. Removing it from the ignored files did the trick.

Here I detailed in other post:



in my case, it was the .ignore plugin (, which does per definition:

"Hide ignored files and directories in the project tree view"


@Adriano Rosa

You saved my day!


Please sign in to leave a comment.