Datagrip IntelliSense in Redshift not working for read-only account

I am using Datagrip with RedShift and can't figure out why the intellisense (code completion) feature is not working with a read-only account. If I connect with an account which is the owner for the schema, it works fine. That kind of tells me it has to do with permissions but a read-only account should be able to use that feature.

11 comments
Comment actions Permalink

Can you please tell us if DB objects are introspected under read-only account?

0
Comment actions Permalink

No sure what you mean by introspected... The read-only account has select permission on the objects. I can query all tables and I can even query system tables like information_schema.columns and pg_class.

0
Comment actions Permalink

Yeah, but in the objects view of the db — do you see tables, views etc?

0
Comment actions Permalink

I see what you mean... No I don't see the objects with the read-only account. What permission would I need for that?

0
Comment actions Permalink

We are talking about 2016.2.1, right?

1. Try to press Sync/refresh button on the top. Does it help?

2. Is there More Schemas... on the bottom? What happens if you click there.

3. If nothing helps try to go to datasource properties tab → Options → Introspect using JDBC metadata.

0
Comment actions Permalink

I was on  2016.2.1 so tried all of above and no luck. I also updated to  2016.2.2 and still the same. When I click on synch, I see the client going through all objects at the button, listing them all, but I still can't browse them and auto complete does not work.

Again, the same setup on the account that owns the schema works fine.

0
Comment actions Permalink

What about point 3 about JDBC metadata, did you try it?

0
Comment actions Permalink

I did try that and that did not work.

0
Comment actions Permalink

What read-only mode lets you depends on the database and the driver.

0
Comment actions Permalink

Not sure what you mean here.

0
Comment actions Permalink

It is not DataGrip issue, it depends on the database

0

Please sign in to leave a comment.