Laravel autocomplete problem

the autocomplete can't work:

this is the correct autocomplete display with a leading slash before the class name:

also this problem happen when the default phpDoc info:

and if I modify it with a leading backslash, the display could be correct:

PhpStorm version: PhpStorm 2016.2.1 Build #PS-162.1889.1, built on August 23, 2016

Laravel version: v5.3.3

Laravel Plugin version: 0.10.1

Laravel IDE Helper version: v2.2.1 

Need help, thanks!

4 comments
Comment actions Permalink

Did it work before? 

Looks like this has to be reported at Laravel plugin page: https://github.com/Haehnchen/idea-php-laravel-plugin/issues

0
Comment actions Permalink

I find a topic here:

https://laracasts.com/discuss/channels/general-discussion/help-using-phpstorm-import-class-only-works-with-leading-slash

till now, don't know where this problem from, PhpStorm, Laravel, Laravel Plugin or Laravel IDE Helper

0
Comment actions Permalink

This is the actual root cause: https://github.com/laravel/framework/issues/701

And here's a corresponding feature request on our tracker: https://youtrack.jetbrains.com/issue/WI-27561

Feel free to vote for it in order to move it up in the queue and receive notifications regarding the progress of the feature. See more information on this at https://intellij-support.jetbrains.com/hc/en-us/articles/207241135.

0
Comment actions Permalink

Thank you very much! I voted this bug and hope it can be fixed ASAP.

0

Please sign in to leave a comment.