File Mapping Issue

I am using PHPStorm 2016.1 under Windows 10.

I am using WAMP and my document root is c:\wamp32\www. I have setup Xdebug on the web server.

My web app project files are in c:\Projects\Project and there is an Apache alias called Project that points to this folder.

Under deployment, I have setup an 'In place' connection:
Web Server root URL: http://localhost
Local path c:\Projects\Project
Web path: /Project (http://localhost/Project)

Under Servers, I have setup a server named localhost:
Host: localhost
Port: 80
Debugger: Xdebug

I have checked Use path mappings. In the left column is the path to my project files: c:\Projects\Project.

What goes on the right side? I have tried: c:\wamp32\www\Project

I have setup a build configuration called localhost with a start URL of /Project/ (http://localhost/Project/).

When I try to debug the web app, it launches the app with XDEBUG_SESSION_START, but it immediately breaks with the following error:

Remote file path 'C:\Projects\Project\index.php' is not mapped to any file path in project.

What am I doing wrong?

 

2 comments
Comment actions Permalink

Do I get right that the Apache alias http://localhost/Project takes you directly to C:\Projects\Project and not to C:\wamp32\www\Project?
If so, there's no need to mention C:\wamp32\www\Project in configuration, as PhpStorm doesn't use this folder anyways.
It just takes the structure from C:\Projects\Project and adds it to http://localhost/Project, generating a URL to be passed to a browser.

Please try removing the Use Path Mappings checkbox.

0
Comment actions Permalink

Eugene,

Thank you for your quick response. It turns out that the actual folder I was using for my project was a junction pointing to another folder, and this evidently caused some issues with PHPStorm, All is working now.

Thanks again...and thanks for a great product!

 

0

Please sign in to leave a comment.