No auto-completione

Answered

Hello.

First, sorry for my english, i'm french.

I have install phpstorm on a ubuntu 16.04.

When i open a old project and writte in a old file i have the auto-completion. But if i create a new file, i don't have the auto-completion.

After search on google, i found i have to check autopopup code completion in setting->editor->general->code completionbut i don't have the code completion.

 

Someone have a idea ?

Thanks

11 comments
Comment actions Permalink

Do you have a PHP tag opened in this newly created file?
I mean, <?php

0
Comment actions Permalink

Hello yes i open with a PHP tag

 

0
Comment actions Permalink

Could you please send us a screenshot of the whole IDE window?
Also, what do you see if you press Ctrl+Space in such a file?

0
Comment actions Permalink

there is the screenshot. When i press Ctrl+Space i have no suggestions

 

0
Comment actions Permalink

Please go to Settings | Editor | File Types |  Text and remove this file from the list below if it's there.

0
Comment actions Permalink

Hello thanks. it's work. But on the setting i have missing section like  code completion or the section update on system.

0
Comment actions Permalink

It's not about completion being turned off for a file, it's about the file being recognized as a PHP file.

0
Comment actions Permalink

Thanks for your help

When i loke at here https://www.jetbrains.com/help/phpstorm/2016.2/updates.html

i understand on setting->apperance there is a update section but i don't have this section.

 

0
Comment actions Permalink

Do you have File | Settings | Appearance & Behavior | System Settings | Updates menu? Can you show us a screenshot of it?

0
Comment actions Permalink

yes i have this section. Sorry i make a mistake.

Thanks for your help.

 

0

Please sign in to leave a comment.