Disable completion of arrow in $this->

Maybe this has been around for a while and I just now noticed it, since I haven't had to write a class for a while, but whenever I type $this-> now I end up with an extra carat mark at the end ($this->>) because it's trying to complete it.  I've been searching for a way to disable this behavior for about an hour to no avail, and it's getting extremely irritating having to either stop short or stop and delete a character.

Where is this feature in the options, and how can I turn it off?

1 comment
Comment actions Permalink

> Where is this feature in the options, and how can I turn it off?

It does not exist yet: http://stackoverflow.com/questions/32583000/turn-off-autocomplete-after-this-in-phpstorm
Please feel free to post it as a feature request: https://youtrack.jetbrains.com/newIssue?project=WI

0

Please sign in to leave a comment.