Code Style Javascript indent problems

So, im using ESLINT, but I cannot get the Auto Indention to work properly.

 

This is what my ESLINT complains about. Its off by two because the export keyword start with 2 indents. (The indent settings are set to 2\2\2).

I tried to be smart and set the indent settings to 2\0\2 but then my code when flat....

 

 

Any ideas?

2
3 comments

In Settings | Editor | Code Style | HTML | Other, add script to the Do not indent children of list:

2

Ahh, thank you Elena!

0

@ElenaPogorelova

You're always my savior. Thank you, and thank you very much.

1

Please sign in to leave a comment.