IDE freezes while Resolving References and overall poor performance


PhpStorm: 2017.3.3 (installed via Toolbox app), Heap size is 2048MB
System: MacBook Pro (Retina, 13-inch, Early 2015) with macOS High Sierra
Java: 8 Update 161
- CPU: 2.7 GHz Intel Core i5
- Mem: 8 GB 1867 MHz DDR3

PhpStorm have a pretty big problem with resolving little bigger project (with tiny one it works well), it does not properly index files and can crash during that process, but even after successful indexing I cannot resolve a reference and after clicking (CMD+Mouse Click) on a reference to a method in the same class it does not work and it locks a IDE in a freeze since clicking [Cancel] does not do anything. I've tried to do the same with all apps closed to improve amount of available resources but IDE still refuses to work properly.

There is also a issue when I double click on a string there as it freezes PhpStorm completely (nothing is working)

In a current state it's impossible to use PhpStorm at all, I've even tried IntelliJ Ultimate with php plugin but same problem occurs. I've tried completely removing all Jetbrains apps with all settings and config files but that did not help either.


Is your project located on a local drive? 

Did you try to run Invalidate Caches & Restart?

Did you try that with all custom plugins disabled?

If you did - please run Help > Collect & Show logs in ... and upload somewhere the resulting archive so we could inspect it.


1) Local drive
2) Yup, multiple times
3) Yup


Ok, I found the issue here, it turns out that there is a file `.phpstorm.meta.php` which content results in a resolving loop, removing that file completely stopped issue from occurring at all.


I had the same issue with RubyMine, i.e. I would type part of a variable name and then RubyMine became unresponsive as it was trying to resolve or suggest the name.  After failing to find a similar meta file I tried the first of @Dmitry's suggestions and the IDE began to work like normal again.


I have the same issue on AppCode 2019.2. I am running the IDE on a very high-end, modern Macbook Pro. More often than not "Resolving Reference" will freeze the entire IDE despite me allocating it plenty of memory. Truth be told, I am using AppCode to maintain a large codebase, but I do not have these kind of issues with Xcode on the same codebase.

It is also worth noting that cancelling out of the "Resolving Reference..." dialog can also take minutes or cause the IDE to not respond.


Same issue with AppCode 2019.2.2 

Attached profiler results to the issue here


For me: opencv+Qt dev stack completely trashes Clion's mod of clangd. Just do some shift-f6, ctrl-space keyboard hits and editor becomes nonresponsible.
The only way i suggest to is disable clangd completion and navigation:


You might want to report this at CLion forums, this thread was initially discussing PHP-related issues.


Please sign in to leave a comment.