Cannot Set SQL Dialect

Answered

I've set my slq dialect multiple times for a project but I does not take.  Intellij keeps telling me SQL dialect is not configured.  Even after clicking on the light bulb and setting it multiple times

2 comments
Comment actions Permalink

Hello,

Where do you want to use the dialect (sql file, string literal)? Please attach screenshots with the configuration you've made and screenshot of the editor.

For SQL file you can set dialect from the file's context menu, for the string literal you can select to inject the specific sql language in the editor (including via annotation comments).

0
Comment actions Permalink

It's working now.  In languages and frameworks > sql dialects I set the dialect and press ok or apply and then when I return the dialect is still there.  That was not happening before.  On a side note fore Scala under Languages and Frameworks > Scala - Performance tab language injection is disabled.

0

Please sign in to leave a comment.