Change default context-click run test to RSpec

Answered

Hi,

 

I don't use Test::Unit/shoulda/minitest, and never have. I want my tests to default to RSpec. My favorite feature of rubymine is being able to cmd + shift + R and run the test I'm currently looking at. I'm not sure if there was a new update or something, but now when I do that it tries to run the tests as Test::Unit. Every time I want to run a single test, I have to create an individual run configuration for it. This is just painful. I'd rather just run rspec in the command line than create a new run configuration for every individual `it` block. 

I know there has to be a way to make this go back to defaulting to RSpec. There would be no point in having that context click run-test feature if it only worked for one type of test.

 

Thanks,

Noah Prince

1 comment

Hello Noah,

sorry for the delay. Do you still experience the issue? What RubyMine version are you using? Have you tried removing the existing run configurations and run tests from the folder again choosing 'All specs..'?

0

Please sign in to leave a comment.