Integrating preexisting subversion through PyCharm?

I am attempting to use PyCharm's VCS and I never used it before so bare with me. Normally, what I would use is TortoiseSVN. For instance, if I wanted to checkout my branch I would simply create a new folder, say sandbox, right click and hit SVN Checkout. It would ask me for a url where I would type something like:

svn+ssh://domain/usr/local/Repository/branches/branch/CodeBase

 

However, I am having trouble setting it up in PyCharm. Here is the process I am taking:

I open PyCharm and in the PyCharm welcome gui I select Check out from Version Cont... and select subversion. The Checkout from Subversion gui opens and I hit the green + sign. I added my svn+ssh and click Checkout. It asks me to select a checkout destination directory. I chose one on my desktop and I click ok. Now the first odd part happens. It takes me to the SVN checkout options gui and in the destinations box it has three diffrent file paths for destinations listed even thought I only gave it the one. It has the one I gave it and two others:

C:\Users\<user>\Desktop\sandbox

C:\Users\<user>\Desktop\sandbox\CodeBase

C:\Users\<user>\Desktop\sandbox\usr\local\Repository\branches\branch\CodeBase

So the first one is the one I select because it is the one I specified. I am not sure what the other two are. So I left the Update/Switch to revision on the HEAD selection and the Depth I left on infinity. I am not sure what the include externals locations checkbox means but its checked. Now I click OK and an error message appears:

Cannot load supported formats: Cannot run program "svn" (in directory "C:\Program Files\JetBrains\PyCharm Community Edition 2018.1.4"): CreateProcess error=2, The system cannot find the file specified

Not sure what I am doing wrong, could someone help me out here?

7 comments

I am experiencing the same issue. I have installed an svn binary and configured the path to it in Welcome to PyCharm->Configure->settings->Subversion. But the subversion command seems to be looking for the svn binary in its own directory instead of at the path I specified. Sometimes the error I have seen seems to indicate that the configuration is confused by a space in the path name (in Program Files).

0

In version 2018.1 we've changed how VCS integration works, see https://blog.jetbrains.com/idea/2018/01/2018-1-changes-to-subversion-integration/

tl;dr: you would need to install command-line SVN client of your choice & specify its full path at File | Settings | Version Control | Subversion.

0

I have that configured with the TortoiseSVN binary at:

C:\Program Files\TortoiseSVN\bin\svn.exe

Checking out this time, I got this error:

Cannot checkout from svn: 'C:\Program' is not recognized as an internal or external command,
operable program or batch file.

It looks like the space in Program Files is breaking the path. Can I escape the space to fix that? (I'm a Mac guy mostly and don't remember how to do that on Windows command lines.) I picked the exe location from a file browser dialog, so I would have expected it to escape the path correctly if necessary.

0

Try surrounding the path with quotes, e.g. "C:\Program Files\TortoiseSVN\bin\svn.exe"

 

0

I'm having the same issue. Surrounding it with quotes doesnt work. When saving the settings phpstorm seems to find it because it I typo the name it will complain about not finding the executable. Somewhere the program is likely forgetting to surround it with quotes when executing it, thus causing this problem

0

I found that there already is an open bug report about it: https://youtrack.jetbrains.com/issue/IDEA-131449

0

Please sign in to leave a comment.