Can't edit a file

Answered

I am feeling a bit silly working with PyCharm. I downloaded and installed version 2017.3.3 on both a Windows machine and a Mac. It seems to have a mind of its own when it comes to using it.

In the create a new project dialog, it doesn't recognize that I have Python 3.x installed. Not to be deterred, I create a virtual environment.

When I create a file within the project and try to type anything, it just dings at me and it won't let me do a thing. Occasionally it will let me type something, but consistently at the start of the program, I can't do a thing.

Thoughts?

9 comments
Comment actions Permalink

Well, I'm sure that this will make sense to somebody ....

1. Create a new project.

2. Give it the file location

3. Resist the temptation to click the drop down for "Project Interpreter." If you couldn't resist, select "New Environment Using Virtualenv.

4. Click Create

5. Click on the Project name, then right click and select New Python File, give it a name

6. Click on the file

7. In the Editor, your cursor should be a flashing block

8. Press the INSERT key on your keyboard!

9. Code to your hearts content!

There must be a setting somewhere or something that is tripping me up, but this process is what is working for me.

5
Comment actions Permalink

Hello! Do you have IdeaVim plugin installed and `Tools| Vim Emulator` enabled? If so please check https://www.jetbrains.com/help/pycharm/using-vim-editor-emulation-in-pycharm-ideavim.html?keymap=primary_default#editing-modes.

4
Comment actions Permalink

Thank you Anna!  That fixes it and explains a lot of questions for someone that has used Windows since DOS 3.3 and is just moving over to Linux. Thanks again!

0
Comment actions Permalink

Hi Anna,

Thank you that fixes my problem.

0
Comment actions Permalink

thanka alot Anna!!!

0
Comment actions Permalink

Alhamdulillah, THANKS ANNA & WMHEID! :)

0
Comment actions Permalink

Thanks a lot. It works for me.

0
Comment actions Permalink

Thanks Anna

 I solved that problem

0

Please sign in to leave a comment.