Javascript debug configuration crashes chrome launch ("parameter is incorrect")

Answered

I have tried reinstalling both chrome and phpstorm with default settings to no avail.

I have the extension for chrome installed (if that makes any difference).

Debug works on my laptop but not my desktop.

13 comments
Comment actions Permalink

Hello,

What PhpStorm and Chrome versions do you run?

How do other browsers behave (like Internet Explorer)?

Please attach a screenshot of File | Settings | Tools | Web Browsers.

0
Comment actions Permalink

Chrome: 67.0.3396.79

PhpStrom: 2018.1.4 (181.5087.24)

I have not tested other browsers (IE has been replaced with Edge on my Windows 10 computer).

0
Comment actions Permalink

Just tried on 2018.1.5, no difference

0
Comment actions Permalink

Do I get right that chrome.exe path is wrong?
If so, please click the Path column for Chrome in Web Browsers and provide it with a proper path.

0
Comment actions Permalink

Eugene's suggestion of manually setting the path worked. I had to set from default to Chrome and set the chrome path manually for the debugger to not throw this error. Are there any suggestions as to how to get the default configuration to work? I'd rather not have to manually set this for every file I'm launching the debugger on

0
Comment actions Permalink

Maybe it has to do something with current Chrome installation - can't reproduce that at both of my Windows 10 systems.

Did you try reinstalling Chrome?

0
Comment actions Permalink

I did, but I will try again and investigate further.

0
Comment actions Permalink

On 2018.1.6, I've had the issue happen even after setting the path to chrome manually. I deleted everything under .PhpStorm2018.1 and reinstalled it to have the manual path setting work again. I will try reinstalling chrome again to see if it will work without manually setting the path. I don't know if my windows version could affect this but here it is

0
Comment actions Permalink

what is the result of running `start chrome` in Windows cmd console?

0
Comment actions Permalink

running start chrome on powershell (on my laptop and my desktop) launches Chrome

0
Comment actions Permalink

should I open a ticket on youtrack?

0
Comment actions Permalink

This is likely a system configuration issue, not a problem in IDE. When a path to Chrome is specified as `chrome` in Settings | Tools | Web Browsers, PhpStorm runs start chrome Windows command to start the browser. Looks as if this command points to the wrong Chrome executable on your system

You can replace `chrome` with a full path to Chrome executable as a workaround

0
Comment actions Permalink

ok. thanks for the support. I will try finding out why my IDE is pointing to the wrong executable then. :)

0

Please sign in to leave a comment.