Ctrl + .

Answered

I had Pycharm 2016.3, recently upgraded to 2018.3
I'm used to holding Ctrl key (Or am too late to release it after I do copy/paste). Since we have to write a lot of "." in python, it keeps closing the current code block, and jumps to the top of it. I've searched in the settings for a key bind and found it under "Editor Actions" named as "Choose Lookup Item And Insert Dot" - I have no idea what this means, but disabling it didn't work. Could anyone point me to where can I disable this ? (Or some workaround?)

Also, a huge new annoying "feature" ? - when I delete everything from the search bar (at the top of the current file I'm editing) When I delete the value in it (Ctrl + A, then Ctrl + X/backspace) The marker jumps to some random place on the page and the whole file scrolls to it - How can I disable this?

Edit: I'm on windows 10, did not have these problems with 2016.3

Thank you

4 comments

Hi Tadas, Ctrl+. is used for Keymap | Main menu | Code | Folding | Fold Selection / Remove region. You need to remove shortcut for this action.

The marker jumps to some random place on the page

Can't reproduce this behavior, could you please update to 2018.1.4?

1

Thank you very much, helped me for the Ctrl + . issue, I somehow missed it in the maps ..

I should've been more clear on the second issue - It happens only if I navigate to a function via "Ctrl + B" (Navigate to where it's defined):
E.x. - I'm in a file A, I press Ctrl + B on some function, it takes me to file B, now if I search for something new, scroll the file, and the delete the new search - it still takes me to what I've searched in the old file with Ctrl + B. I hope I've made a clear enough description. What I'd like to do is disable this completely (deleting search never takes me anywhere)

Edit: I've also upgraded to 2018.1.4

Thanks again

0

Got it, thank you for the detailed steps. This seems to be a known issue: IDEA-191340, unfortunately, it's impossible to disable this behavior. Please vote for the ticket to prioritize the fix.

1

Please sign in to leave a comment.