Help Please: Debug session was finished without being paused: Acquia Dev Desktop 2

Debug session was finished without being paused

It may be caused by path mappings misconfiguration or not synchronized local and remote projects. To figure out the problem check path mappings configuration for 'vet.dd' server at PHP|Servers or enable Break at first line in PHP scripts option (from Run menu). Do not show again.

I am running a drupal project Acquia dev desktop.

My projects files are: C:/Users/vet/Sites/devdesktop/vet

My apache,php,mysql etc:C:/Users/vet/DevDesktop

php 5.3: windows 10

Thanks, vetYoa

 

JetBrains Uploads

Upload a file and note the exact file name to the JetBrains support channels.

The data uploaded will only be used for the sole purpose of investigating a support case.

Max file size: 1Gb

xdebug.log (521 kb) 100%

 

[Select files] [Upload files]
5 comments

Hi Eugene Thanks for your prompt response.

My set up is changed little bit. I am getting the breakpoints hit in all the functions except in hook_menu function Drupal 7). But every time debugging ends with "Debug session was finished without being paused".

Here is my set up: Windows 10, phpstorm, acquia dev desktop 2 (Drupal 7) with Xdebug v2.2.7, Copyright (c) 2002-2015, by Derick Rethans.

I created project 'New Project from Existing files' and chose option 1: web server installed locally, source files under document root. My project files are also in document root.

Why my breakpoint in hook_menu function is not hit?

function vet_menu() {

Thanks for your help..Look forward to your response please..
0

What happens if you enable Run > Break at first line in PHP scripts? Will it stop the execution and start the debugging after that?

0

Hi Vladimir

Thanks for your response that I was waiting for. Yes, it does stop and starts the debugging after that. I don't get the 'Debug session finished message'. What does it mean 'Break at first line...' and what does it do?

Other issue that I mentioned above is the following. Please respond to that as well:

Why my breakpoint in hook_menu function is not hit?

function vet_menu() {
$items[].... breakpoint here but not hit?
 
Thanks for your help..Look forward to your response.
 
0

> Thanks for your response that I was waiting for. Yes, it does stop and starts the debugging after that. I don't get the 'Debug session finished message'. What does it mean 'Break at first line...' and what does it do?

It means that we will always break at the first line of any PHP script. It looks like you did not configure path mappings or configured them wrong.

Please run Run | Web Server Debug Validation to check your web server configuration. Also check Settings | Build, Execution, Deployment | Deployment > your remote server > Mappings tab and Settings | Languages & Frameworks | PHP | Servers for correct paths.

> Why my breakpoint in hook_menu function is not hit?

It can be because of the mappings issue mentioned above. Are you sure that this function is actually being executed?

0

Please sign in to leave a comment.