django sqlite3 database not configured correctly in pycharm

Answered

I'm currently continuing a django project on windows originally written by a mac user, and I am using the PyCharm IDE. I had a lot of trouble getting the database set up for the project (using the default sqlite3). My DATABASE settings are correct, and when I check the connection the the database when running manage.py shell it says that it is connected.

The only issue is that every variable that is there to access data in the database is highlighted in red, which is typically a sign of an error in the JetBrains IDEs that I've worked with. I'm still able to host the site locally what could be the cause of this issue/error? I've a couple examples of what I mean below:


EDIT: I know there is a problem because if I run a model independently I get the following exception:

django.core.exceptions.ImproperlyConfigured: Requested setting DEFAULT_INDEX_TABLESPACE, but settings are not configured. You must either define the environment variable DJANGO_SETTINGS_MODULE or call settings.configure() before accessing settings.

but the DJANGO_SETTINGS_MODULE was already configured correctly to the right app. Any ideas?

1 comment

Hello,

could you please specify what errors re highlighted in the Editor (you can check if those are errors by red lines in the right margin in the Editor). In addition, how does it go in case you run Django Run configuration?

0

Please sign in to leave a comment.