Structure Tool Window content often invalid

Hi guys!

For some time me and my colleagues have encountered some strange behaviour in PHPStorm.

The Structure Tool Window is working strangely.

First, the content of the window often stucks. It doesn't refresh, if I switch between open files, it's content often shows delayed information, or just simply nothing. I have to press some button on the window (for example ABC sort) to make it refresh it's content. (We're working with 3-8k line classes with lots of methods and keeping the tool window open all the time.)

Second, if you put it on float mode, then you can't put back below the Project Tool Window in split mode, only float and windowed mode is possible. Reinstalling PS and reloading exported config settings doesn't help either.

Performance Summary Report:

Filesystem Info:
File system is case sensitive: false
Are there symlinks: false
Number of files: 6940

System Info:
Number of CPU: 4
Used memory: 231Mb
Free memory: 77Mb
Total memory: 309Mb
Maximum available memory: 725Mb
Displays:
Display 0: 1920x1080; scale: 1,00
Display 1: 1366x768; scale: 1,00
Display 2: 1920x1080; scale: 1,00

Project Info:
Number of opened files: 2
File size (in lines): 3086
File size in characters: 125043
Number of injections: 0

IDE Info:
Custom plugins: [BashSupport (1.6.13.181), YiiStorm (0.9.16.3)]
Disabled plugins:[]
Build version: PhpStorm 2018.1.5 Build #PS-181.5281.19 June 7, 2018
Java version: 1.8.0_152-release-1136-b39amd64
Operating System: Windows 10 (10.0, amd64)
JVM version: OpenJDK 64-Bit Server VM JetBrains s.r.o

Could you help me?

Thanks in advance!

Laci

6 comments

Hello,

> First, the content of the window often stucks. It doesn't refresh, if I switch between open files, it's content often shows delayed information, or just simply nothing. I have to press some button on the window (for example ABC sort) to make it refresh it's content. (We're working with 3-8k line classes with lots of methods and keeping the tool window open all the time.)

This must be https://youtrack.jetbrains.com/issue/IDEA-183801 - please vote with thumb up button.

> Second, if you put it on float mode, then you can't put back below the Project Tool Window in split mode, only float and windowed mode is possible. Reinstalling PS and reloading exported config settings doesn't help either.

Just open the tool window settings and click on the currently active mode - either Floating or Windowed - to uncheck it and make it return back to the main frame.

0

Hello,

thanks for the reply.

I voted thumb up on that issue.

The second solution you are writing doesn't work. I've tried this before I posted here, 'cause it used to work but it doesn't any more.

Can you suggest any other solution?

Thanks in advance!

0

Well, it definitely works for me in that way.

Could you record a video of that behavior please?

0

@Laszlo Bejczi

Please try "Window | Restore Default Layout" -- will it make any difference?

You may also try deleting the .idea subfolder (while IDE is closed; backup first if desired) -- that's where this project settings are stored and start from scratch (use "Open" and point to the project root folder and then configure as needed). You could edit "workspace.xml" file manually, but I do not know exact options to edit to have your Structure window back to "fixed" position.

P.S. Have you tried it will all custom plugins disabled? Worth checking it in any case.

0

The "Window | Restore Default Layout" worked, thank you!

0

Please sign in to leave a comment.