Turn off ASCII arrows replacement on unicode arrows

Some time ago in older version of Idea I turned on autoreplace of => into ⇒, -> →, <- ← .

Now in my new team conventions don't accept this style of arrows.

I used import of settings on my new working place, settings.jar was generated on older version of idea, now I use 2017.3

I don't remember where I turned it on in that version of idea but it definitely wasn't a live template and now I can't find it to turn this autoreplace off. Right now I googled this option and only find how to do it in the Live Templates section - but I don't have anything related to this arrows in live templates.

Please help me turn it off.

I can send my settings.jar if it will help.

Permanently deleted user

Here you are:


Go to Settings | Editor | Font and then uncheck “Enable ligatures”


Please sign in to leave a comment.