Pycharm can't render Epydoc docstrings

Answered

Hi,

I'm having an issue when I try to read the documentation from opencv functions I get an error :

I'm working with Python3.6, OpenCV3.4. Python2.7 is also installed on my system.

 

Thanks

10 comments
Comment actions Permalink

Hi Jonas,

 

The suitable interpreter is looked up among those configured in the IDE (it has to be Python 2 since Epydoc package itself hasn't been ported to Python 3 yet). In other words, you need to set up it once so that it showed up on the list at Settings | Project: ... | Project Interpreter | Show All... -- it doesn't need to be actually used in any project. Is it true in your case?

11
Comment actions Permalink

Thank you Mikhail, it works!

1
Comment actions Permalink

Guys, not sure what I am supposed to do. I installed Python2 but then I installed Epydoc in the project settings .. I'm lost. I do not want to change the whole project to 2.7. Thanks.

[EDIT] I figured it out. I needed to add the Python 2 to the list of environments. 

BUT

The documentation is unreadable as it does not respect line break in the documentation. It's just one big blob ;(

5
Comment actions Permalink

Hi, Guys! I have same problem as Tomi. Python 2 and Epydoc are installed, but Quick Doc is unreadable. Here is screenshot for well known inRange function from OpenCV:

It looks like documentation is read but not "rendered".

How to fix it?

1
Comment actions Permalink

Hi there!

The problem is that it's not really Epytext. OpenCV uses Doxygen for documentation that we don't support and also confuse with Epytext because of the similarity of tags. There is an open issue about it.

1
Comment actions Permalink

Hey if someone still has problem in this issue. i hope my case be helpful.

in my case, this issue cased by uncheck "Show on Mouse Move". i tried reinstall pycharm and reset my ide setting but still said "You need configured Python 2 SDK to render <a href='http://epydoc.sourceforge.net/'>Epydoc</a> docstrings". so in my case i have 2 computers same OS as macOS(big sur 11.1, both intel. i think it is not related but anyway).

i export my setting from laptop(mac air) and import to desktop(mac mini) and it works. i think this is SDK path issue like environment variable. but i don't know how pycharm manage them. i upload my setting file you don't need unzip it. just import it. i hope this help you

setting file : https://drive.google.com/file/d/1NejTeyZZ-sqADBRLq4xlck86rOXaz8VP/view?usp=sharing 

0
Comment actions Permalink

Thank you Tomi Trescak it works.

"File" -> "Settings..." -> "Project: <your_project_name>" -> "Python Interpreter" -> Click on "Gear" icon -> "Show All..." -> Click on "+" button to add Python 2 interpreter (I added it as "System Interpreter")

0
Comment actions Permalink

Hi Eido,

I'm trying to do the same as you, but I have a question.

Do I need to have python 2 installed in my PC to use it as a system interpreter?

Thank you

1
Comment actions Permalink

Yes, you need to have it installed locally. Rendering docstrings with a remote interpreter is very wasteful in terms of resources.

1
Comment actions Permalink

Thanks Mikhail Golubev! It worked for me

0

Please sign in to leave a comment.