RUN simply stopped working for one single project which previously worked fine (no changes to configuration)



- Using community edition 2018.1.5 (reinstall didnt help)

- Using Java 1.8.0_121 (exactly the same as from before the issue)

- Reimporting projects didn't help

- Fetching it again in different path - didnt help

- Removing idea folder and iml files didnt help

- Invalidating caches didnt help

- Run button is present while clicking on main function and on main class.

- Run is grayed out next to "THE SAME" run configuration at the top-right (its the same configuration ive used previously - nothing changed)

- There are ZERO logs about what went wrong...

- "Running" application simply does "nothing" - Before Launch "Build" option is completely neglated, who when i rebuild project it works fine


Im really buffled, spent like 3 hours now banging my head against it, because it makes no sense.


I'm experiencing this same issue on IDEA 2018.1.5 Ultimate.

It's very basic project with jdk8, javalin (kotlin) and lombok dependencies, with main class on it. IDEA is behaving exactly as others wrote, it does nothing on run button click and then run button disappears. Same goes for debug button etc.

I'll try tomorrow with IDEA 2019.

btw as others pointed out, disabling Gradle 181.5281.24 plugin makes everything work fine (even if it's maven project).


@Marcin Gorgoń could you please upload the project, including project configuration files (.idea sub-directory and module's .iml files) and your File | Export settings... jar. For uploading you can use / or any file sharing service. Thank you.


Sure, uploaded to However, I didn't received any ref except file name.


Thank you. Unfortunately, still could not reproduce it. Please try 2019.1 version.


I also have the same problem suddenly, the logs output this error:

Version used: 2019.1

2019-04-29 10:51:23,613 [ 521150] INFO - ij.compiler.impl.CompileDriver - null keys not supported
java.lang.NullPointerException: null keys not supported
at gnu.trove.THashMap.put(
at com.intellij.util.graph.GraphGenerator.buildOuts(
at com.intellij.util.graph.GraphGenerator.<init>(
at com.intellij.util.graph.GraphGenerator.generate(
at com.intellij.util.graph.impl.GraphAlgorithmsImpl.computeSCCGraph(
at com.intellij.util.graph.impl.GraphAlgorithmsImpl.computeStronglyConnectedComponents(
at com.intellij.compiler.ModuleCompilerUtil.computeSourceSetCycles(
at com.intellij.compiler.ModuleCompilerUtil.getCyclicDependencies(
at com.intellij.compiler.impl.CompileDriver.b(
at com.intellij.compiler.impl.CompileDriver.make(
at com.intellij.compiler.impl.CompileDriver.make(
at com.intellij.compiler.CompilerManagerImpl.make(
at com.intellij.task.impl.JpsProjectTaskRunner.c(
at com.intellij.compiler.options.CompileStepBeforeRun.a(
at com.intellij.openapi.application.TransactionGuardImpl.runSyncTransaction(
at com.intellij.openapi.application.TransactionGuardImpl.lambda$submitTransaction$1(
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.doRun(
at com.intellij.openapi.application.impl.LaterInvocator$FlushQueue.runNextEvent(
at com.intellij.openapi.application.impl.LaterInvocator$
at java.desktop/java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.desktop/java.awt.EventQueue$ Source)
at java.desktop/java.awt.EventQueue$ Source)
at java.base/ Method)
at java.base/$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.desktop/java.awt.EventQueue.dispatchEvent(Unknown Source)
at com.intellij.ide.IdeEventQueue.defaultDispatchEvent(
at com.intellij.ide.IdeEventQueue._dispatchEvent(
at com.intellij.ide.IdeEventQueue.dispatchEvent(
at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.desktop/ Source)


The exception is not related to discussed here problem. Please try deleting IDE Caches directory and restart.


Had the same issue, run/debug command was not doing anything and was getting disabled after the first click. Disabling the Gradle plugin resolved the problem.


I have similar problem.

IntelliJ IDEA 2019.1.3 (Ultimate Edition)
Build #IU-191.7479.19, built on May 28, 2019
JRE: 1.8.0_202-release-1483-b58 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Linux 5.1.5-arch1-2-ARCH

I've created a new maven project via Spring Initializer (plain project, no enabled features). Running the project first time seems to work, then running it a bit later hangs on the Build.
If I restart the IDE, then the first time works fine, but after awhile, trying to run it again fails. Same running tests or debugging.

If I disabled Gradle plugin, I still get the problem.


Please file a bug at with idea.log and build.log attached: .

Also provide the thread dumps of IntelliJ IDEA and build processes (jps) using jstack: .


Thanks for the solution and yes disabling the gradle plugin worked for me even though I have a maven project


I have a maven project and had run into the same issue after upgrading some of my Serenity dependencies.

I can confirm that disabling Gradle plugin has helped me out.


Locate the temp working directory for IDE, for instance win7 have it under C:\Users\<<user>>\.IdeaIC2017.3

Delete this directory, and reimport your project.

Worked for me!


'File > Invalidate Caches / Restart' worked for me


I see people talking about disabling gradle plugin in their maven project.

I am having same issue in a multi-module project, but I can't find any gradle plugin in my maven project.

Can someone help me find this gradle plugin?


Hey, It is found in the intellij plugins (not maven plugins)

Use shift twice and search for the intellij plugin menu


I am still having this issue, was this ever solved. I have a java gradle project where if my before launch configuration is “build”, it blows up saying that it can't find any classes. If I change the launch configuration to “build project” it works fine. This is a bandaid as now the build takes about 4 times as long since it will be building unnecessary dependencies for each app.


Michael Greco Please provide a sample project with the steps to reproduce the issue. You can attach it to the private support ticket at


Please sign in to leave a comment.