How to turn off show variables for run in 2017.3.3?

Completed

I use the run window to show the output of my programs.  In 2017.3.3 the show variables sliding window keeps appearing when I run and rerun my programs.  I turn show variables off via the icon on the run tab and it keeps reactivating at each and every run.  How do I turn this permanently off so it does not keep activating?

3 comments

I discovered how to do this.  In the drop down for the file you are running click on 'Edit Configurations...'  and then uncheck the 'show command line afterwards' option.  I do not know how this got checked.  Now the show variables option is not available which is fine for me.

0

Same problem here, but not "show command line afterwards" in " Edit Configurations". Also, showing the command line shouldnt' be related with showing the variables..

 

0

Found it:

File > Settings > Build, Execution, Development > Console

Then uncheck the box "Show console variables by default". Apply, Ok,

 

Thanks to Stackoverflow: https://stackoverflow.com/questions/53062242/how-to-turn-off-the-special-variables-window-in-python-console-of-pycharm

0

Please sign in to leave a comment.