PhpStorm 2017.3 uses 100% CPU

PhpStorm 2017.3 is constantly using 100% CPU even if no processes are running.

I already tried to invalidate cache and restart but the problem persists after the indexing is done.

Isn't there a PhpStorm specific task manager to see what it's doing? (like the one on Chrome)

5 comments

No, unfortunately there's no task manager.

Current tasks are displayed in a View > Status Bar (a bar in a bottom of IDE). It might show "indexing ..." or "scanning files to index".

Is your project on a local drive? Are there any symlinks? Did you try to disable all custom pluings (Settings/Preferences > Plugins > Show: Custom)?

0

I've got the same issue. 

Status Bar is empty but phpStorm is going crazy in the background. 

Out of nowhere it pushes all my 16 threads to 50% load for like 2 minutes and goes back to 0 afterwards. 

Never had this before... super strange

 

0

Please use "Submit a request" link at the top of this page and provide CPU snapshot/idea.log there. See https://intellij-support.jetbrains.com/hc/en-us/articles/207241235-Reporting-performance-problems

Each person will most likely have different reasons for such behaviour (machine/config specific cases). There is no single solution for "me too" cases.

0

I just found out that the high CPU usage is caused by a javascript file.

Cleaning it up, I also found that is specifically this line of code that generates the high CPU usage:

$('<div>').appendTo($form);
0

Please sign in to leave a comment.