How to prevent auto-formatting vue-loader's deep selectors?

Answered

When reformatting code in `.vue` files, vue-loaders deep selectors `>>>` get spacing between them like so: `> > >`, which in effect breaks their functionality. Is there any way to prevent it from happening?
Currently I'm using `@formatter` comments so they are not reformatted, but it's tiresome: 

<style scoped>

//@formatter:off
>>> .custom {//@formatter:on
transition: none;
}
</style>

I'd like to just add custom formatting ignore option for `>>>` selectors (as a custom input perhaps), but couldn't find how or if it's possible.

1
3 comments

This is addressed in the upcoming 2018.2 version. https://youtrack.jetbrains.com/issue/WEB-26828

I'm also unable to reproduce this on 2018.1.6 so the fix was probably backported to 2018.1.6.

 

1

Yikes! Thanks @Dmitry, I was not aware of the existing issue.
I've updated PHPStorm to the most recent version and the issue seems resolved.

0

You're welcome! :)

 

0

Please sign in to leave a comment.