Files supported via TextMate bundles missing??

I added a new TextMate bundle based on this Sublime package and it looks fine.  Only issue is when I go to File Types the options for "Files supported via TextMate bundles" is not there so I can't assign it.  Any idea why? Attached is the bundle I was trying to use and a screenshots.  This bundle uses the .htm, .html and .xml filetypes and I already unregistered the defaults so that I could use these.  I can't figure out why I do not have that option to assign them to .html files?


Even better idea, how can I just add these custom tags and parameters to the existing HTML language since I need to use the HTML language with it anyway?  The file extension will be .html in the end.


can anyone help me get this working?  I am close but I need to get the new Antlers syntax working WITH the HTML syntax.  How can I do this?


Got the same issue. This option is gone. It shouldn't according to

Also, I got the issue, that the theme remains "Default". And all my settings are ignored.
Posted a screenshot in this related issue on GitHub:

It seems that these issues are bugs in PhpStorm:

- Missing "Files supported via TextMate bundles" option
- Ignores selected theme

I was able to tell PhpStorm to "Mark as textmate" with right click on the Vagrantfile. Maybe because it wasn't associated to any other file type. So maybe it helps you, when you remove ".html" from HTML Files in File Types, to get this option as well. But it's just a guess. 


Hi there,

The File Types entry for TextMate bundles is gone as planned (as per my understanding of what is said in .. so the documentation should be updated at some point.

No idea about ignored theme. I guess file a ticket to the Issue Tracker .

P.S. Not using TextMate bundles myself so cannot say more about expected/correct behaviour.


I have come across the same issue. I can name my Vagrantfile as Vagrantfile.rb and PyCharm uses my installed ruby TextMate bundle and highlights the file. My bundle is correctly associated with Vagrantfile but Vagrantfile and .Vagrantfile do not apply syntax highlighting. I think I may have broken association at some stage and cannot edit association as the "Files supported via TextMate bundles" option does not exist. It must be in an App properties .xml file.I actually found this, which does work. While they issue is supposed to be fixed in early 2019 it has since broken form me but added the Vagrantfile.xml and then marking file  as "Vagrant Configuration File" worked.


@Andrew Ge-Hall

Cannot say anything about PyCharm .. but for PhpStorm you can check this comment, maybe it's the same for PyCharm as well:

P.S. For PyCharm, found this ticket, says fixed for next major 2020.2 version.


Andriy Bazanov, Thanks for the quick response and finding of related ticket. Good to know I wasn't going mad with having highlighting then it disappearing.


Please sign in to leave a comment.