Webstorm not detecting angular project

I have a project with the following structure:

- client (Angular-CLI generated project)

      package.json

- server (Express project)

     package.json

package.json

Where both client and server projects have their own package.json files. The outer package.json is just used for scripts that start the whole project.

So, when I'm working with that project I open the root folder containing both client and server code. For some reason when I open the project this way, I don't get any highlighting for the client project. Like this:

Basically, the IDE doesn't get that I'm working in a directory with Angular-CLI project.

Is there anything I can do about it?

2 comments
Comment actions Permalink

You likely have client/node_modules marked as Excluded, right? Angular support can only be enabled if the corresponding @angular modules are included in index; for node_modules located in the project root this is done automatically - WebStorm scans the direct dependencies in root package.json and auto-adds them as libraries; for nested node_modules, however, this has to be done explicitly:

- open Settings | Languages & Frameworks | JavaScript | Libraries, press Add...

- press +, choose Attach files

- select the client/node_modules/@angular folder, OK

 

When project re-indexing completes, Angular support should be there

 

1
Comment actions Permalink

Hi, I'm working on a Nativescript project (that uses Angular) and it's happening to me as well.
including the files as mentioned did not work

0

Please sign in to leave a comment.