Debugging Karma Launches Parallels instead.

My setup is karma along with karma-webpack plugin, mocha, sinon, chai and sinon-chai and launching Chrome.   The tests run fine with normal testing but I cannot debug.  When I debug using the karma runner, it launches Parallels (on mac) instead.   I have also tried Running Karma, and then using a JS Debug runner instead.  The JS Debug runner also launches parallels instead.

I also notice that when running Chrome with Karma, plugins are not included so I'm not sure how Webstorm can debug tests with Karma if the browser is not including in the Jetbrains debugging plugin for Chrome.


2 comments
Comment actions Permalink

It's a Parallels issue - see http://youtrack.jetbrains.com/issue/WI-36#comment=27-70940;

see https://youtrack.jetbrains.com/issue/WI-36#comment=27-604896, https://youtrack.jetbrains.com/issue/WI-36#comment=27-1887395 for possible workaroulds.

You can also try to specify a full path to Chrome app in Web Browsers preferences (Preferences | Tools | Web Browsers):

  1. Change "Path" of Chrome to /Applications/Google Chrome.app (as opposed to /Users/<Username>/Applications)
  2. Change "Default Browser" to "First listed" (and make sure the one you just changed is at the top of the list)

see https://stackoverflow.com/questions/28664762/running-an-app-in-webstorm-on-macos-with-parallels-installed

 

>I also notice that when running Chrome with Karma, plugins are not included so I'm not sure how Webstorm can debug tests with Karma if the browser is not including in the Jetbrains debugging plugin for Chrome

Since 2017.3, Chrome extension is not used for debugging by default - see https://www.jetbrains.com/help/webstorm/2017.3/debugging-javascript-in-chrome.html#ws_js_debug_chrome_default_profile. Chrome protocol with --remote-debugging-port option is used instead.

If you like to debug with extension, as before, please enable Update application in Chrome in Preferences | Build, Execution, Deployment | Debugger | Live Edit

See also https://blog.jetbrains.com/webstorm/2018/01/debugging-javascript-with-webstorm-2017-3/

 

1
Comment actions Permalink

Thank you for the quick and informative response.  Disabling share applications with mac in each of my VM configurations resolved the issue.  

1

Please sign in to leave a comment.