Getting incorrect server info for xDebug incoming connection

I'm using PHP storm with the remote connect back setup. I had one project that was working fine and started working on a second one. Unfortunately, debugging isn't working quite right, and I can't figure out how to fix it. I'm getting the settings below:

However, this project is on port 80 (not 443) and the file path should be /var/www/opweekends.api/...

I can't edit the fields here and I can't figure out where to set them up. I have a server setup in PHPStorm, and the fields are correct there, but since I'm not using an IDE Key for xDebug, I'm not selecting that server for xDebug.

I can't figure out what to do.

1 comment

Hi there,

Has to be something wrong on your end (I mean -- the path).

Thing is: that "File path on server" is sent by Xdebug to IDE when Xdebug establishes debug connection (just in case: it's Xdebug that connects to IDE and not other way around). You can see that from Xdebug log (xdebug.remote_log)

"Server Name" is used by IDE to detect what config (path mappings) to use. Mappings and stuff can be configured at "Settings/Preferences | Languages & Frameworks | PHP | Servers".

Questions:

  • Do you have more than one project opened at the same time? Maybe IDE fails to recognize which project to use..?
  • IF you do -- will it work if you leave only one project opened?
  • What IDE version do you use?
0

Please sign in to leave a comment.