Docker as Project Interpreter on Windows Missing /opt/.pycharm_helpers

Completed

Hi

I am trying to configure Docker on windows to run as a remote Project Interpreter following the instructions at https://www.jetbrains.com/help/pycharm/configuring-remote-interpreter-via-docker.html. I've had a lot of trouble here, PyCharm will frequently just hang, particularly if I click on "Python Console," and I have to kill the process. Following the instructions doesn't appear to work and, I must be missing something basic because, I don't understand how it can work.

Starting from no Docker images/containers, following the instructions (which use python:latest) will give you three images:

1. busybox:latest - Pulled straight from dockerhub

2. pycharm_helpers:PY-173.4301.16 - Put together as a copy from the local PyCharm helper files in C:\Program Files\JetBrains\PyCharm 2017.3.3\helpers

3. python:latest - Pulled straight from dockerhub

It will also result in three created containers with the following container name [command] details:

1. /pycharm_helpers_PY-173.4301.16 [/bin/sh]

2. some_container_name [python /opt/.pycharm_helpers/packaging_tool.py list]

3. another_container_name [python -u /opt/.pycharm_helpers/generator3.py -v -L]

But the last two containers will surely die, because /opt/.pycharm_helpers is not mapped to anything in these containers and so the pycharm_helper files are just not available.

Please let me know if I can provide further information. I have tried with both 2017.3.2 and 2017.3.3 and get the same result both times.

Regards, J

0
2 comments

You should check the volumes created. I add a similar issue and it came from the fact that I deleted the volume pycharm_helpers volume. Simple running `docker run -v {project_name}_pycharm_helpers_{pycharm_build_number}:/opt/.pycharm_helpers pycharm_helpers:{pycharm_build_number}` solver the problem

1

This looks to be a local issue due to specific firewall settings. Thank you for your time and apologies for the error.

0

Please sign in to leave a comment.