Can't pull from / push to GitHub "alert protocol version"

Answered

Today, I found that PyCharm was no longer able to push or pull from GitHub. It can still see all of my repositories. However, if I choose "test" from the "clone repository" window, or attempt to pull or push from an existing repo, I get an error message like the one in the dialog below. I have tried deleting my JetBrains configuration and starting over. I have not yet tried completely uninstalling and reinstalling PyCharm because that takes forever.

I should say that I can happily pull and push from the same repositories at the command line.

 

5 comments

For me, also git from the command line showed the same error. Downloading and installing the newest version (both git and pycharm) fixed it.

0

On February 22nd GitHub is dropping weak cryptography algorithms - https://githubengineering.com/crypto-removal-notice/. As a result some systems and older git clients will stop working. Please update your git client.

-2

Hi, I'm using the built-in git client. There are no plugin updates available. Command line git works just fine.

0

Found this bug that has a workaround: https://youtrack.jetbrains.com/issue/PY-28653.

Switch to native SSH executable in Settings | Version Control | Git | SSH executable

0

Please sign in to leave a comment.