Open File or Project Dialog Box Unresponsive After IntelliJ IDEA Update

Answered

I just updated to IntelliJ IDEA version 2170.3.3 (also tried 2017.3.5 but uninstalled it for same problem). When I start the application it launches the "Welcome to IntelliJ IDEA" dialog where you can select among:

Create New Project, Import Project, Open

In each case the next dialog that appears relates to selecting a location for the install. Once this dialog appears the whole application freezes and nothing is shown in terms of directories, etc. Also the Cancel button has no effect. From this point the only way to shut down IntelliJ from Task Manager.

I have install - remove - re-install several times, I made sure all remnants of previous installations where removed (including all registry keys), I have updated Java rte to latest version. Nothing works.

Could someone please help with this issue.

0
14 comments

Please share the logs and the thread dumps:

https://intellij-support.jetbrains.com/hc/articles/207241085
https://intellij-support.jetbrains.com/hc/articles/206544899

The issue can be caused by the slow network drives. Try disconnecting all the network drives.

1

No, it's not, there are many more recent builds available, but the sorting is confusing:

Also try https://www.jetbrains.com/idea/nextversion/.

1

I can't disconnect network drives these are set by group policy - besides, this is like the 4th version of IntelliJ IDEA I use and I've never had this problem; the previous version I was using didn't have this issue.

Below are the logs,

https://pastebin.com/raw/t0gJA0wQ

0

This forum is not suited for posting long logs and file attaches. Please use some file sharing service or report a bug at https://youtrack.jetbrains.com/issues/IDEA. As stated above, we need the thread dump of the frozen IntelliJ IDEA process as well.

0

Is there any reason you are running IntelliJ IDEA on the old Oracle Java build instead of using the bundled JetBrains Runtime?

Switching back to JetBrains Runtime should help: https://intellij-support.jetbrains.com/hc/articles/206544879.

2018-03-15 15:58:49,867 [ 7] INFO - #com.intellij.idea.Main - JRE: 1.8.0_45-b15 (Oracle Corporation) 
0

No particular reason, I've always used that one.

When these freezes there are a series of files that appear in the:

...\.IntelliJIdea2017.3\system\log\threadDumps-freeze-20180315-161031-IU-173.4301.25 directory.

These files just keep appearing every sec or so for as long as IntelliJ IDEA is open.

 

The first few lines of the file are below.

 

"AWT-EventQueue-0 2017.3.3#IU-173.4301.25 IDEA, eap:false, os:Windows 7 6.1, java-version:Oracle Corporation 1.8.0_45-b15" prio=0 tid=0x0 nid=0x0 blocked
java.lang.Thread.State: BLOCKED
on com.intellij.openapi.util.IconLoader$CachedImageIcon@2a74b59c owned by "ApplicationImpl pooled thread 11" Id=82

0

That is exactly the bug that is caused by your old Java version. It can be easily fixed by using the default bundled Java Runtime or Oracle Java 8u92 or later, see https://bugs.openjdk.java.net/browse/JDK-8138764 for details.

See also https://youtrack.jetbrains.com/issue/IDEA-179723.

0

How IntelliJ IDEA decides which JRE to use? I uninstalled everything. Install Java JRE 1.8.0_152 then re-install IntelliJ IDEA 2017.3.3 and when I start it the thing says IDE's Java runtime (1.8u45) should be updated to at least 1.8.0u144.

Is there a registry key or similar that determines which jre is used?

0

The exact process of defining which JDK version to use is described in the great detail at https://intellij-support.jetbrains.com/hc/articles/206544879.

0

I am using JDK installed by the Bintray plugin (verified in "About" window), still getting stuck in the open-file ("Apply patch") dialog

IntelliJ IDEA 2017.3.4 (Ultimate Edition)
Build #IU-173.4548.28, built on January 29, 2018
Licensed to JAROSLAV ZÁRUBA
Subscription is active until July 12, 2018
JRE: 1.8.0_152-release-991-b1 amd64
JVM: OpenJDK 64-Bit Server VM by JetBrains s.r.o
Windows 7 6.1

0

This JDK build is older than the none installed by default with IntelliJ IDEA 2017.3.4.

Also, your problem may be different. You need to switch to the default bundled JDK and if the issue persists, report a bug at https://youtrack.jetbrains.com/issues/IDEA with the thread dumps attached.

0

I have switched to that one because of this issue, hoping it would cure it.

0

(Yes, I created a report already: https://youtrack.jetbrains.com/issue/IDEA-188457 )

The JDK (b991.1) is the newest the plugin offered to download & install.

0

Oh admn, thanks. Yeah I noticed 76 is right after 152, still got caught by this one. :)

Thanks, I have cleared gradle caches meanwhile, and now the problem is gone. Will try next time it arises.

0

Please sign in to leave a comment.