Errors compiling code with armadillo and GNU emacs


/tmp/ccALHjhs.o: En la función `TLS wrapper function for arma::arma_rng_cxx11_instance':
inversa.cpp:(.text._ZTWN4arma23arma_rng_cxx11_instanceE[_ZTWN4arma23arma_rng_cxx11_instanceE]+0x21): referencia a `arma::arma_rng_cxx11_instance' sin definir
collect2: error: ld returned 1 exit status



I install armadillo with all requeriments but it don't work.

Help. I have a error when I compile this code:

#include <iostream>
#include <armadillo>
using namespace std;
using namespace arma;
int main(int argc, char** argv)
mat A(4, 5, fill::randu);
mat B(4, 5, fill::randu);
cout << A * B.t() << endl;
return 0;

I don know how fixed it. Help please.

Tatiana Shabaeva
Official comment


Have you tried to build the project in Xcode - does it provide the same compilation error?

Are you sure you're posting this in the correct community board? Are you trying to use this library in an iOS or MacOS application? This board is for users of AppCode, JetBrains' IDE for creating Mac and iPhone/iPad apps.


Please sign in to leave a comment.