Remote interpreter -> Using the wrong one!

Answered

Hello,

I'm using Pycharm remote interpreters on 2 servers but from time to time I find the IDE stuck using one interpreter even if I tell it otherwise.

Basically I have 2 interpreters:

 - [Local desktop] DL which maps to /home/ekami/workspace/remote on 192.168.1.150

 - [Local tuatini server] DL which maps to /home/tuatini/workspace/remote on 192.168.1.161

So for a given project I configure the remote interpreter as in the picture below:

As you can see the path mapping maps to /home/ekami/workspace/remote/Torchlite. Here are the captures for the Deployment pane as well as the configuration:

But each time I launch the "srgan eval" script I get in the console:

ssh://tuatini@192.168.1.161:22/home/tuatini/Programs/anaconda3/envs/dl/bin/python -u /home/tuatini/.pycharm_helpers/pydev/pydevd.py --cmd-line --multiproc --qt-support=auto --client '0.0.0.0' --port 42187 --file /Users/Ekami/workspace/Torchlite/examples/srgan.py eval
bash: line 0: cd: /Users/Ekami/workspace/Torchlite/examples: No such file or directory
pydev debugger: process 18035 is connecting

 

WHY it is connecting to 192.168.1.161 when I asked it to connects to 192.168.1.150?? It's driving me crazy and It's the third time it happens to me and the 2 last times I had to completely redo my whole Pycharm configuration. I lost hours doing this. I'm 99% sure that's a bug because most of the time it works and then after 2-3 months using Pycharm the problem occurs again...

Thank you for your help.

 

EDIT: I found why... There is a "Python interpreter" option in the Run configuration, it was not set on the default for I don't know what reason. I find this whole thing very confusing to change the same options to 3 different places.

Please sign in to leave a comment.