Git commit, no changes detected (problem solved)

Answered

Hi all :

After I edit a file and commit, it always shows " No changes detected ", and the file I edit, the color change to not what I usually seen before.

Normally should change into this color, right?

 

Meanwhile,  local changes always show " default " after I edit any files in the project.

 

I am not sure it's IDE's problem or git's problem, so I use Sourcetree application, and it worked with commit and push to my GitHub successfully.

Here's my IDE Settings / Version Control view

And my Help / Show Log in Explore  file link

http://goo.gl/UEqstz

 

My develop environment OS Windows10, Webstorm version is 2018.1.

6 comments
Comment actions Permalink

Seems the status of the files shown as Ignored.

Make sure they are not added to Settings - Version Control - Ignored Files list.

4
Comment actions Permalink

Oh yes, it's been added into ignored files for some reason I don't  know. Thank you so much!

0
Comment actions Permalink

Dmitriy Smirnov answer worked for me perfectly in Webstorm

1
Comment actions Permalink

I came across this thread with a similar problem. But in my case, even though the changed files were reflected in other IDEs, it still didn't appear in the dedicated window in Webstorm. To fix this I have found some setting (which is not so clear in my opinion) to control that. If you turn this OFF, it will add the Default Changelist view.

Preferences → Version Control → Commit → Turn OFF the "Use non-modal commit interface"

That's the Changelist view:

2
Comment actions Permalink

otomer

Not sure why this is considered similar.

When the Use non-modal commit interface option is enabled, there is the Commit toolwindow on the left, that shows the Local Changes (where Default changelist resides) and allows committing from there. See https://www.jetbrains.com/idea/whatsnew/#version-control

Commit action (Ctrl/Cmd+K) navigates to the toolwindow.

So you don't need to disable the setting to see the changes list.

1
Comment actions Permalink

The solution described above solved my problem.

0

Please sign in to leave a comment.