No output in debug console [WEB 2018.1][Win]

I recently updated my WebStorm to 2018.1, and found that I'm not getting any console logging while running my node app in debug mode. It works as expected when running it without debugging.

Running a React app in debug mode also yields the same issue. When I roll back to 2017.3 everything works as expected.

[Edit]: Uninstalling and reinstalling toolbox and other apps did not fix the issue

[Edit]: Cleared settings for all versions of WebStorm, still no luck

[Edit]: Draggin this out of the comments:

Console in 2018.1:

Console in 2017.3.5:


Works fine for me - when debugging Node.js app, console.log messages are printed to both Console and Debugger Console panels. Is your Debug toolwindow docked? What Run configuration do you use for debugging?


I've got the debug panel pined to the left, and using a "npm run" run configuration.

I'll try docking/undocking the editor


Just updated WebStorm on another windows computer and I have the same issue. Uninstalled WebStorm and reinstalled with default settings, and no JetBrains Settings Sync, no luck still.

Used the debugger in both floating mode and windowed mode, still no output ether.


Works for me when using NPM run configuration as well.


What does your npm script look like? Sample project that shows up the issue would be appreciated


Recorded a video of my issue:

Notable Timestamps:

0:04 - Fresh install, default settings

0:22 - Generate clean react app

0:50 - List of enabled plugins

1:24 - List of disabled plugins (none)

1:30 - Bundled plugins (not sure if different then the enabled list)

2:05 - Create basic npm run configuration

2:20 - Run without debug ( console works as expected )

2:43 - Run with debugging ( console is empty, app still boots )


with NPM run configuration, logging is shown in Debugger Console panel.

Anyway I'm not sure what you are doing... What's the reason to run `npm start` in debugger? what are you trying to debug? React scripts? You need to make sure that debug options are passed to Node.js when spawning child processes then, debugging is not possible otherwise (as WebStorm can only pass options to the main process)


I'm expecting the same console output that was shown while running without debugging, as that was what happened in WebStorm 2017.3.

Recorded the same process in 2017.3:


Ah, thanks. I tried to find a relevant Issue in YouTrack but couldn't find one


Anthony Dunk omg, thanks a lot!

Some like 3 years ago I'd been using Console every day. Then, all of a sudden, it just stopped working: whenever I typed something there, it would never reply me back simply echoing my commands. And it haven't been functioning for me until now.

Yeah, it was a great mistery for me why it stopped functioning, and I did't dare to unveil it by my own. But today I've finally left my comfort zone (thanks maybe to Covid-19) and decided to Google for it! And - TADA! It worked. 


Now seriously: that silly button should have been enabled by default.


>Now seriously: that silly button should have been enabled by default.

it's not an issue in new WebStorm versions: since 2018.1, Node.js debugger has 2 console windows, one for process.stdout, stdin, etc. and another - "live console" for expressions evaluation. So this button is not there anymore


See, Process and Debugger consoles in the Node.js debugger.

Note also that the 'live' console has bee re-designed completely in 2019.1 (


Please sign in to leave a comment.