Breakpoint error messages in JavaScript area

I made a breakpoint in <script></script> line and above error message appears when I put mouse cursor on the breakpoint.

Currently I'm using Chrome and I already uninstalled Firefox, but the message '~in Firefox' keep showing.(However debugging works well anyway)

How can I remove this annoying message? I'm using IntelliJ IDEA ultimate.

12 comments
Comment actions Permalink

Very strange... What IDEA version do you work with? What does your .html file look like? Please attach screenshot of the file with error plus your idea.log (https://intellij-support.jetbrains.com/hc/en-us/articles/207241085-Locating-IDE-log-files)

0
Comment actions Permalink

I'm using 2018.1 version.

My .html file is simple:

<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="UTF-8">
<title>JavaScript Test Page</title>
</head>
<body>
<script>
var num = 20;
console.log(num);
</script>
</body>
</html>

In this code, I made a breakpoint in 9th line(var num = 20;) and above error message appears.

 

p.s. I can't capture screenshot. It looks like the IDE blocks it.

0
Comment actions Permalink

IDE definitely doesn't block screenshots capturing. You were able to create a screenshot of the error, weren't you?

Your code looks normal, and I don't have issues creating breakpoints in similar code

Please try capturing a screenshot and provide it along with idea.log

0
Comment actions Permalink

I attached screenshot. How can I attach idea.log? I can't upload non-image files.

0
Comment actions Permalink

Please upload it to some file server and provide a link here

BTW, is the issue specific to certain project? Please create a new project using New | Project... | Static Web | Static Web, add .html file to it - does the issue persist?

0
Comment actions Permalink

What project is it? Go, Python? Can you share a project that can be used to recreate the issue plus your settings (File | Export Settings)?

0
Comment actions Permalink

https://drive.google.com/file/d/1T5fDknyEBGcvZYS99mZlHFTJRx5Mq7Ei/view?usp=sharing 

(This is my settings.jar file)

 

I tested in new HTML file of Static Web project. Source code is same with my first answer.

0
Comment actions Permalink

No luck even with your settings (tried with a new Static Web project)

I suspect that your .html files are actually assigned to a different file type (Go/Python template, etc.)

Is the static web the only project you have open?

Please provide your settings folder (~\.IntelliJIdea2018.1\config ) + a test project

0
Comment actions Permalink

https://drive.google.com/file/d/1qfmxurBxWWyyxtcB2OCp7-FsWyqoYdBZ/view?usp=sharing 

(config + test project)

 

| Is the static web the only project you have open?

No, I'm using Go, Python, Java and PHP projects.

 

0
Comment actions Permalink

Thanks, recreated. The issue is caused by Python plugin. Logged as https://youtrack.jetbrains.com/issue/PY-29609, please follow it for updates

0
Comment actions Permalink

Thanks for creating issue.

0

Please sign in to leave a comment.