XDebug setup no finding files locally


I can't get PHPStorm to map my files locally, even though they seem to be linked correctly

I am debugging from the browser. Symfony files are on a Vagrant env. Incoming connection is being picked up, but I get an error Cannot find file locally. To fix it set server name by environment variable PHP_IDE_CONFIG and restart debugging session. I have added this (on linux vagrant command line export PHP_IDE_CONFIG="serverName=SomeName" as stated in the docs. No luck. I have tried with and without this setting.

xdebug settings

message in phpstorm debugger window

I am letting PHPStorm do the settings like this:

when that fails, I add in root project setting

But it just won't make the connection. Been at this for a while. I've never had debugging in PHPStorm not work like this, so not sure what I could be missing. Thank you


Found it -- I hadn't named my nginx server. This showed up in the Webserver debug validation checklist -- which is now loading with the above settings. Happy and debugging again.


Please sign in to leave a comment.