PHPStorm 2018.1 keeps indexing

After the last update to PHPStorm 2018.1 projects keeps indexing every ±10 seconds. I already tried invalidate caches and restarting PHPStorm. I even removed the .idea directory from the project and created a new one, but the result is the same. 

Does anyone have a suggestion on how to solve this issue?

12 comments
Comment actions Permalink

Please disable .ignore plugin if you have it installed (and Invalidate caches one more time just in case).

https://youtrack.jetbrains.com/issue/IDEA-189189

2
Comment actions Permalink

Please try upgrading to the 2018.1.1 EAP build, a couple of platform issues that could cause that were fixed there.
https://www.jetbrains.com/phpstorm/eap/
If it's still happening, please submit the log bundle (Help | Compress and Show Logs) within a support ticket: https://intellij-support.jetbrains.com/hc/en-us

0
Comment actions Permalink

I've hit this too. Invalidating caches and restarting didn't fix the issue. It's killing my machine.

0
Comment actions Permalink

Thank you very much Andriy, disabling the .ignore plugin fixed the re-index problem.

 

Phew. That really drove me nuts. I'll revert back to simply managing ignore files by myself. It's not that big a deal anyway.

 

Cheers

0
Comment actions Permalink

The latest .ignore plugin (v2.6.1) should have that issue fixed anyway. Maybe you were still using an old version?

0
Comment actions Permalink

Same version 2018.1, .ignore plugin disabled but still indexing all the time over and over again!

0
Comment actions Permalink

My experience is Phpstorm keep indexing after I upgrade and install the ideaVim. I tried the method above with no luck, then I remove the ideaVim plugin and it stops indexing now. I looks like many plugins will cause the indexing problem.

0
Comment actions Permalink

CPU 350%, there is no way to stop it, so terrible.its so terrible ,MacBook air crashed.

PHPstorm 2018

 

0
Comment actions Permalink

Is it just indexing? How long did you try to wait? 

0
Comment actions Permalink

In my case, constant reindexing was caused when I accidentally removed read permission for the project root directory; restoring the permission solved the problem. (Also, loads of log entries about virtual files not being found were generated.)

0
Comment actions Permalink

I stopped the Laravel project's public folder from the indexing issue solved.

0
Avatar
Vladimir Luchansky
Comment actions Permalink

@Pele Odiase Are there any other custom plugins?

Did you run File > Invalidate Caches/Restart > Invalidate and Restart?

-1

Please sign in to leave a comment.