[Solved] prettier doesn't show up in settings

Edit: Solved by Elena Pogorelova in the comments, apparently the help entry is currently outdated as of 2018-04-11. To get a "prettier" entry in the settings, the plugin must first be installed by opening the settings, selecting plugins and then pressing the "Install Jetbrains plugin..." button. Search for "prettier", install and you're good to go after a restart of the IDE.

Hey there!

I'm new to IntelliJ and trying to add a proper tslint+prettier to my typescript project. Got it working in Visual Studio Code for a previous project, but can't get the prettier settings entry to show up in IntelliJ IDEA:
What I've done so far:

Installed NodeJS and configured it as an interpreter according to the Prettier help page:

I've also already activated the NodeJS-Plugin:

I've also ran the 'npm install prettier --save-dev' command, and tried 'npm install prettier -g' later, too. You can see this in the second screenshot, prettier shows up in the installed packages.

Prettier does work in VSC, but I can't get the menu item to show up in the settings of IntelliJ. I've already tried to restart the IDE several times.

I'm still guessing this is a user error since I'm new to the platform, but I've followed the help page and can't get it to work. Does anyone know how I can get the entry to show up?

Comment actions Permalink

You need installing Prettier plugin: in Settings | Plugins, press Install Jetbrains plugin..., choose Prettier:

it will the there after restart:


I've created https://youtrack.jetbrains.com/issue/WEB-32191 to fix documentation bug

Comment actions Permalink

Thank you very much, this solved my problem! I searched the plugin list for a "prettier" plugin, but it wasn't immediately obvious that the list only shows locally available plugins.


Also thanks for creating the ticket, may help more people in the future :)

Updated my original post with your answer to give it better visibility and preserve it.


Please sign in to leave a comment.